View Full Version : command line rendering with Maya 8 OS X working?

11 November 2006, 11:12 PM
I just got Maya 8 Unlimited and apart from the issues with Tiger and mental ray satellite covered in the other thread, I can't get a proper render out of the command line with mental ray, regardless of whether it's networked or not. here's what's in my ~/.bash_profile:


that makes render show up fine.

here's a simple caustics test, rendered in Maya:

and the same image rendered in the command line:

and the render exits with the following error:

Error: Scene /Users/beige/Documents/maya/projects/default/scenes/caustictest4.mb failed to render.

MSG 0.0 info : wallclock 0:03:36.24 total
MSG 0.0 info : CPU user 0:05:11.43 total
MSG 0.0 info : allocated 2 MB, max resident 25 MB, RSS 0 MB
// Maya exited with status 210

I just ran memtest and all is fine.

the command was as follows:

render -r mr -cam persp -rgb 1 -alpha 1 -fnc 3 -s 1 -e 1 -percentRes 100 -of tif -im "caustic4_persp_g5solo" -rd "/Users/beige/Desktop/renders/" /Users/beige/Documents/maya/projects/default/scenes/caustictest4.mb

that's running only on the local machine that has 4.5 GB of RAM on a dual G5. even weirder, I tried to increase the memory for the render (-mm 1500) and got this:

Invalid flag: -mm.

and from the help: "-mm int Renderer maximum memory use (in Megabytes)"

does that not apply to mental ray?

any ideas what the hell is going on? i never had these issues with Maya 7. This is a fresh install of OS X 10.4.8

11 November 2006, 12:54 AM
ok, i seem to have fixed it for other renders but it still chokes on this one with that // Maya exited with status 210 error. anyone seen that?

finally got network rendering working on Tiger too - they should be shot for
such shoddy development. hopefully there's a fix coming in the next update so not everyone has to figure out how to jumpstart xinetd or launchd...

01 January 2007, 12:43 AM
I get the same message with this commandline render:
Invalid flag: -mm.

and from the help: "-mm int Renderer maximum memory use (in Megabytes)"

render -r mr -rd \Finalrenders -rl true -mm 400 m513_03.mb

CGTalk Moderation
01 January 2007, 12:43 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.