View Full Version : MoCap Animation Transfer Problem: MB7.5 to Maya7.0.1

10 October 2006, 03:52 AM
I have a character in MB7.5 that I've animated using vicon motion capture data in the following way:

1) Importing a bare biped skeleton rig that was exported to FBX by Maya7.0.1
2) Characterizing the skeleton rig
3) Importing the .c3d mocap data
4) Creating an actor and marker set with optical input from the .c3d
5) Aligning the characterized skeleton and actor as closely as possible
6) Setting the character to take input from the actor and activating the actor input on the character
7) Save character animation to an .fbx (binary) file

8) Open original rig in Maya
9) Import saved character animation
10) Exclusive Merge

Now when I get to the part where I import the char. anim. (.FBX file) into Maya and tell it to merge, i get the following error:

"FBX Import Error

Node _____ has to resample its rotation because it has a PreRotation.
Since the node also has rotation limits, those limits cannot be applied due to the resampling and will be dropper"

I get this for 6 of the joints in my rig.

The animation transfers roughly, however the feet of my rig
are upturned (ankle rotate unnaturally so that the foot is basically parallel with the leg) and the arms seem to be doing the animation facing the opposite direction (elbows bend backward). I can't figure out what's going on with this, anyone have any hunches or flat out solutions?


10 October 2006, 06:14 AM
I had such issues with older fbx format, not sure how i fixed it with joint limits.
I think i unchecked the limits and reimported the motion, and that solved my problem.
But i can suggest get new FBX format, should work.

10 October 2006, 10:04 PM
Serg my man. I am having a similar problem. Is it because I am using the old Kaydara FBX motions from 4.0?

11 November 2006, 03:13 AM
I miss the old simple FBX export options *sigh*

Okay I figured it out. Maya 7.0 to MB 7.5.

I went onto the Autodesk website ( and downloaded the latest FBX plugin for Maya 7.0. and installed it.
I re-exported my original skinned character with the correct joint hierarchy names. I used the following settings. (see attachment "maya7_to_mb75.jpg")
Oped the FBX file in Motionbuilder 7.5.
I characterized my character in motionbuilder 7 by draging the character onto my mesh and then activated the rig. I named my character snugman.
I imported a character motion in. I used one of the old Kaydara FBX 4.0 motions called "kicks" just to see if there was a compatibility issue.
Made made "snugman" driven my the motion by switching from "Control Rig Input" to "Character driven Input". Snugman is now Chuck Noris doing crazy round house kicks.
I then slect my "snugman" character and do the "Plot Character" option. A window pops up and I say to "skeleton".
I then export my fbx file. I don't include any animation takes but the ones I need.
I am back in Maya 7.0 now. I open the original file I exported from. I import the FBX file and use the following import settings. (see attachment "mb75_to_maya7.jpg")
That is all folks. I will check back to see if anyone still has a problem that I might be able to help with.

11 November 2006, 06:07 AM
That fixed all of my problems! Thanks alot! I got so caught up with the problem it never occurred to me that the import plug-in itself would be the problem.

11 November 2006, 06:02 AM
I am glad I could help. You should really thank Xcomb though. He has been my mentor since summer 2003 in helping me fix things in Maya and motionbuilder. I would still be a lost soul in finding my direction if it were not for him. I am always obliged to help as he has for me.

11 November 2006, 07:29 PM
I've been there and done that among other junk to get this to work. I'm using Maya 6.5 so it still has the same issue. I downloaded the plug-ins, checked the Alias website, A.R.E.A, other forums and still nothing. I found a workaround (sort of) but its like trying to duct tape a broken water main. I capture my raw .fbx files with MB 7.5.1, open MB 6.0 and save as, then proceed with the plot junk,etc..into Maya 6.5.1.It works, but I have to be ultra careful, sometimes it just doesnt work for some reason. If you have any suggestions to ease this mind boggling madness, feel free to repost...Thanks.

CGTalk Moderation
11 November 2006, 07:29 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.