LC #42 Pipers Alley

View Full Version : Shiny cylinders with no material

09-28-2006, 02:05 PM

I'm pretty green in 3D altogether, but have started a project of modelling a building to improve. However, I've noticed that when I render a view of my first stage, the columns - as show in the picture - look odd as if they are metallic/very shiny. I have not added any materials to anything yet, and I'm using the internal render engine with AO enabled at 8 samples.
Does anyone have a possible explanation to why the columns seems so different from everything else. There are only 2 lamps in the scene placed over the roof:

The columns are just a cylinder set to smooth and nothing else.
It might be nothing, but I jsut want to make sure there isn't something odd going on before i continue with this.

Thanks in advance!

09-28-2006, 02:59 PM
Try selecting the cylinders and click on the "auto smooth" button and tell me what happens then.

The auto smooth button is in the editing menus (F9 key on the keyboard).

09-28-2006, 03:04 PM
ok I have used the "Set smooth" button in the Edit panel - is that the one you mean?

Otherwise, I'll have another look once i get home from work.

09-28-2006, 03:36 PM
There's an auto smooth button in the Mesh panel of the F9 editing context menus.

It's on the right of the "set smooth button". Here's a screen shot:

(The auto smooth button is in the middle "mesh" panel, at the top)

Now if you set smooth for cylinders, you have to click the auto smooth button or else you'll get these black lines which you're seeing in your building:

09-28-2006, 03:39 PM
Edit: Great responses and examples of getting the best smoothing results.

09-28-2006, 05:10 PM
Thank you very much for the excellent example - and it works fine. The columns display much better now - better got through and check the rest now :D

09-28-2006, 05:19 PM
I actually made a mistake in the render picture.

The middle text (the red one) shoud have said "set smooth only" not "auto smooth only".

Sorry about that.

09-28-2006, 05:30 PM
Ok i see what you mean, and it exaplins what I was getting at first a bit better with that render. But all fixed now :)

09-29-2006, 01:02 AM
Actually you are fixing the side efects, but are leaving the cause untouched. Those black areas are caused by flipped normals.

Make sure that ALL your normals are pointing the right way and you won't have "tha black fever", no matter what your autosmooth settings are.

Cyclical objects, like cilinders and torus, are troublesome for the automatic normal arranging algoritms, so you may need to go in and manually edit the normals to get them right.

Le golo
09-29-2006, 09:52 AM
:wise: The sectors black are not forcing a problem of normal, but simply a problem of smooth with blender which regle.

09-29-2006, 11:30 AM
:eek: ok now i'm confused again.

How can I determine the oritentation of normals?

09-29-2006, 04:44 PM
And normals can be recalculated outside by selecting (in edit mode) mesh->normals->recalculate outside or CTRL+N, if keyboard shortcuts are your cup of tea (and they should be, for Blender is almost all about them).

09-29-2006, 11:50 PM
Yup fine - I have no problems with the keyboards shortcuts in belnder - but I'm struggling with the concept of what it is that i am actually doing by "recalculating/flipping" the normals. Perhaps this is "3D basics 101" and in that case I apologise for being a dimwit - but i just don't see how this ties in - so I hope someone can explain it :shrug:

09-30-2006, 03:18 AM
3D basics 103 :)

Once upon a time... every face/poligon on the 3D world has a normal. Simply put, it is a vector or pointer that origins on the center of the face, goes in a direction perpendicular to the surface of the face and points to one side of the surface.

Usually, when the normal of a face is pointing on the general direction of the camera it is said that the face is toward the camera. That is the principle of the "backface cudling", where faces with normals not pointing toward the camera are ignored at render time.

On plain language, a normal is a mark, present on every single face, that signals wich side of the face is "outside" and wich side of the face is "inside". Unless told otherwise, most 3D softwares will only care about the "outside" side of a face, ignoring or rendering in black the other side..... see where I'm going?

When you have a mesh in edit mode, activate the "show normals" button to see a graphical representation of where the normals are pointing.

In general terms, the most desiderable situation is when all the faces that form the outer shell of a mesh have their normals pointing outside.

Blender has quite a bunch of tools to deal and manipulate the normals of a face, to much to explain in here, so I'll just name them. Most of these tools are on the edit buttons or in the mesh menu.

"Draw (Face) Normals"
"Draw V(ertex) Normals"
"N(ormal) Size"
"Double Sided"
"No V(ertex) Normal Flip"
"Set Smooth"
"Set Solid"
"Auto Smooth"
"Recalculate (Face) Normals Outside"
"Recalculate (Face) Normals Inside"
"Flip (face normals)"
"Shrink / Fatten Along Normals"

Note that we have both face normals and vertex normals. Most of the tools are to manipulate the face ones. The tools that deal with the vertex ones are mostly for the paint modes.

Also note that the "Nor" channel in the texture buttons, the one that you use for bump mapping" is for image based manipulation of the face normals (and thus the name). The "Disp" channel is closely related to face normals as well.

Now, speaking of the situation at hand, normals are escential to smoothing a face. The only difference between a "smooth" and a "solid" face is the way normals are accounted for rendering. On a "solid" face only one (the real) normal is calculated for each face. On a "smooth" face. a bunch of fake normals are calculated (about one normal per pixel) and the direction of those fake normals are calculated taking into account the directions of the real normals in the nearby faces, in order to create a soft transition between the fake normals of one smooth face and the ones from it' s neightbor faces.

09-30-2006, 06:19 AM

I just tried the auto smooth again.

Here you see the difference between having no auto smooth on the left and having auto smooth on the right.

Here are two more screen dumps of the scene with and without auto smooth.

Both the orange and the blue cylinders have been recalculated normals.
The orange cylinder has no auto smooth.
The blue cylinder has auto smooth.
The first screen dump shows the orange cylinder's editing menus (F9 menu) with the auto smooth button not activated yet.
The second screen dump shows the blue cylinder's editing menus (F9 menu) with the auto smooth button activated.

I came across this problem before when I tried smoothing cylinders and I was wondering why I kept seeing these weird black lines even though I had recalculated the normals a million times. I made a post on Elysiun (which is now known as VBulletin on blender artist) asking for this problem and some guy told me to click on auto smooth.

Here's my thread which I mentioned above:

My previous versions of Blender e.g. Blender 2.25 worked like a gem, I did not need to use the auto smooth button. However, with the new releases of Blender like 2.41, the auto smooth button needs to be checked.



If you learn physics, you'll notice that normals are the force which is perpendicular to the surface of an object. This applies to Blender as well since 3D is basically trying to create real life graphics in some way.

For example, if you were a car (the cube) on a high speed banking race track (the triangular prism), the race track would emit a perpendicular force to your car (which you can see in the screen dump). This perpendicluar force is called the normal. The normal is the result of the centerpetal force and the reaction force to the weight of your car.

In Blender, each face has a normal which determines it's direction. When you do stuff like hairs (static particles) and radiosity rendering, you'll start to put consideration into normals and the direction which they point:

You can display normals for faces when you have selected them and gone into the F9 editing menus. In the F9 editing menus, there's a button called "Draw normals" - click on that to display normals. Change the normal length to 1.0 for better viewing of the normals (aqua lines in the screen dump and screen shots).

To flip normals, press the W key and choosing Flip normals when you have the face(s) selected.

Hope that wasn't too bad to understand.


09-30-2006, 11:50 AM
... My previous versions of Blender e.g. Blender 2.25 worked like a gem, I did not need to use the auto smooth button. However, with the new releases of Blender like 2.41, the auto smooth button needs to be checked...

That is called a BUG and should be reported on the bug tracker, did you report it already?

09-30-2006, 06:51 PM
Thanks for the great explanations - it does make sense in terms of dealing with it an of course the physics side of it. Its just not something I'd expect to have an effect when making a basic shape like a cylinder. So I guess that I need to check through my model quite carefully to check the normals before I go any further.
But this has helps a lot guys, so thank you. I'm starting to get to grips with it, but of course "laerning by doing" often mean that you miss some of these basic points untill you need them :)

10-03-2006, 09:52 AM
Hi again :)

Rather than making A new thread I thought i'd post my next question in here again.

I have worked on a bit on the model since last, and found out about the normal. I went through my model and found a few areas where I had to flip normals because things had ben mirrored and somehow it seems that the normals hadn't been. But now for my next question :)
On the imag below, a more closeup render, there appear to be light coming through the dome on the rooftop:
The border on the top of the picture is quite strongly illumuniated. I only have two lamps in the scene, both sitting well above the dome. So I don't see how I should be getting that strong a reflection on the inside of the dome. I have AO enabled, but I wouldn't expect that to cause anything like that :shrug:
I have checked normals and the dome and edge on top is ok for sure, so I'm not quite sure how light is managing to travel through. This isn't as critical a problem as renders of the full building once its finished is unlikely to be at that angle, but just getting paranoid about getting the meshes right now.
Has anybody else had experience with similar issues?

10-04-2006, 01:12 AM
Well . . . by default, lamps don't have shadows enabled. Check to see whether your two lamps are casting shadows or not.


10-04-2006, 07:53 AM
Dooh :banghead: I had a feeling that it might be something simple! Thank you - I'll try that out later today.

10-04-2006, 07:00 PM
Well i tried out the shaded rendering and it turned out that it was not caused by this. However, it helped me isolate the problem and i found that a cube up on the tower section accidentally had been assigned a material which caused really sharp reflections.
But here's the much improved render with shadows anyway - with the problem fixed

10-04-2006, 07:20 PM
Glad to see you were able to fix the problem.

The model is coming along nicely . . . I really like the unusual mix of architectual styles. Keep up the good work!

BTW: What kind of scene/project is this going to be a part of?


10-04-2006, 09:36 PM
Yeah its and odd mix of styles indeed - but it's real :)
It's not designated to be part of anything particular.
The model is based on the theatre just down my own street. I went down with a digital camrea and snatched some "reference" photos from street level (only of the front of the building which is by far the most complex).
So its just for practice, but if it turns out well, there's a small church and the public library on the same row along the street which I could potentially add :) But let's just get this one done first! I'm fairly new to Blender/3D in general, but have tried out the methods for texturing/lighting etc before embarking on this, but i'm not working fast at the moment, so its mostly for practice.
Once i get a little bit further I will probably add a 3d/WIP thread though.

Thanks for all your help so far - I will undoubtedly be back!

CGTalk Moderation
10-04-2006, 09:36 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.