XM Magdalena 3D print, GGeorgy (3D)
LC #42 Pipers Alley

View Full Version : Evasion X-Dof Installation Problem

09-27-2006, 12:17 AM
Does anyone have this plug in? How did you install it?

Today I purchased the plug in but I canít install it. The installation instructions in the manual say:

Install the plugin with following commands:

XSI -i xdof_lens.spdl
XSI -i xdof_output.spdl
XSI -i xdof_intensity.spdl

What do they mean by that??

I also tried the Plug in manager and did Plugins/Load and when I select the .dll files, xsi tells me its an the ďfile in not a valid plug inĒ

I have 2 computers:

Computer 1 Ė XSI 64 5.11 and Windows 64 bit

Computer 2 - XSI 32 5.0 and Windows 32

Can anyone please help?

09-27-2006, 02:46 AM
and btw, i got the X-Dof for mental ray version 2.1

09-27-2006, 03:08 AM
I know how you feel, I installed it about a year and a half ago on XSI 4. It was confusing enough that I took notes about what I did. Here are my notes from that install they may still be applicable to XSI5:

1) Copy the six files from the plugin folder to the location of the xsi bat file. (c:\Softimage\XSI_4.0.Foundation\Application\bin)

Xdof_lens.spdl xdof_intensity.dll

Xdof_output.spdl xdof_output.dll

Xdof_intensity.spdl xdof_lens.dll

2) Open a Dos prompt and navigat to c:\Softimage\XSI_4.0.Foundation\Application\bin From the Dos prompt run the following commands:

xsi -i xdof_lens.spdl <enter>

xsi -i xdof_output.spdl <enter>

xsi -i xdof_intensity.spdl <enter>

A confirming DOS window should open after each command displaying file information.

09-27-2006, 04:17 AM
You just install them from the plugin manager ?
Open up the plugin Manager File/plugin manager,
click the spdl tab and hit the install button.
browse to the spdls and install them one by one.


09-27-2006, 05:02 AM
Thanks for trying to help man!

Here is what I did.

I copied the plug in files into the bin folder

I deleted C:users folder to start over

Opened the command prompt that was in xsiís start menu folder, and ran those commands. A new window came up telling me in copied the files.

When I open xsi, I see the SPDLís in my plug in manager, but not the xdof shaders

09-27-2006, 05:05 AM
FuriousD, are you talking about the xdof plug in or generic plug ins? With xdof there is this license thing you got to run in the beginning, so I donít think it will just let you open up the plug ins through the plug in manager.

09-27-2006, 05:28 AM
Okay, breakthrough! After I followed those stops, I guess I actually installed the plugin BUT, somehow I cant select it. The reason Iím saying it is thisÖ I can open the test scene that came with the plug in and render with xdof. But when I want to add a xdof lense manually, I look at the available list and cant see it.

09-27-2006, 05:52 AM
OKAY, got it.. i just had to open up a preset that was in a different directory:

Iím happy I got it to work, but Iím also angry that the manual just left out all these details!

09-27-2006, 07:51 AM
There may be an emission in the XDOF manual, but it wouldn't have hurt to read up on your XSI manual for installing shaders. All your deleting/installing efforts would have been so much easier.

And oh... please don't cross-post problems over multiple forums before running out of answers on one. It's very hard for other users to crosss jump forums looking for an answer.
And if you find an answer, please reply to -all- forums you posted.

happy rendering btw,


CGTalk Moderation
09-27-2006, 07:51 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.