View Full Version : Steps to make A:M Crash and dissapear without warning.

01 January 2003, 06:29 PM
Find below a bug that I reported and Steve's response to me: I have tested this now on 4 different computers and I can get it to crash every time. I now have a Pentium 4 with 1 Gb RAM and 80 Gb of harddrive space and the NVIDIA GeForce 4 video card.

< Answer from Hash support below>

This might be video card related- have you updated your video card drivers-
I was able to repeat the first example once, but not again, this is not enough for us to use unfortunately-
I suggest not using perspective mode, and never click the render icon, then not use it without hitting <esc> to cancel the operation-

On 10/3/02 1:01 PM, "Marco Napoli" <> wrote:


I included a my steps on how A:M is crashing. Please remember that it does not crash on the same steps, its usually different in my tests to learn A:M.

Thaks for the help.

----- Original Message -----

From: Support <>
To: Marco Napoli <>
Sent: Wednesday, October 02, 2002 5:20 PM
Subject: Re: ver 9.5 closes itself

I would need exact steps to be able to repeat the crashes here to be able to help further-
I can do nothing with “it just crashes all the time”

On 10/2/02 1:54 PM, "Marco Napoli" <> wrote:

I have updated to the latest version of A:M 9.5z and I also experience the same problem with Alpha 10 Beta.

I did this test on two different computers. I reformatted both computers, and reinstalled Windows XP (I even tried using the Windows XP SP1 pack but same results).

The I installed A:M. I am able to start A:M without any problems. I create a new simple model like a wine glass, attached bones. Create a new animation, create a new Choreography, import created model, import created animation, they try to do something and A:M dissapears and my work does not get a chance to save. This is very consisent, I have had this problem since I have tried to use A:M. It does not always crash in the same point. Sometimes it crashes faster, but I am almost never able to stay in A:M for more than 2-5 minutes at a time.

I am not able to be productive, and it is fustrating. But I love A:M and would love to find a way to get around this problem. I have tried both OpenGL and DirectX with same results.

I have all of Windows XP latest upgrades (all). I have tried using the latest video drives, older one, but same result.

Thanks for you help.
Peace in Christ
Marco Napoli

----- Original Message -----

From: Support <>
To: Marco Napoli <>
Sent: Monday, September 02, 2002 1:53 PM
Subject: Re: ver 9.5u closed itself after I deleted a Camera Path

For Frequent crashes, crash on startup:

I'd suggest downloading the most current version of the software from our
website, software updates page <>,
make sure you have the most current video card drivers/extensions installed
(including the latest version of Direct X on the PC),
are running in 1024x768, millions of colors. Also, update your OS (9.2.2 on
a Mac, on the PC, use “windows update” to retrieve <ALL AVAILABLE> not just
critical updates).
If this does not resolve the issue try switching video drivers in our
software by holding down the <shift> key during startup, then , using the
tools/options/global tab to try either OpenGL or D3D for better performance-

On 8/31/02 11:43 PM, "Marco Napoli" <> wrote:

ver 9.5u closed itself after I deleted a Camera Path.
I have also had A:M close itself without any warnings after I was using keyboard shortcuts to UNDO.

A:M closes itself down without warning quite often, and I do not have a chance to save work that I did up to that point.

I am using Windows XP with 512 MB RAM, 100 GB of hard drive space between two drives, a Pentium 4 1.8 GHZ, NVIDIA GeForce 2 video card

Peace in Christ,
Marco Napoli

Steve Sappington
Hash, Inc. -3D character animation tools!
400 West Evergreen Blvd.
Vancouver, WA 98660

01 January 2003, 07:09 PM
Ugh - been there done that. It can be maddening when the crashes are random. And although they seem consistent, the description you gave makes it seem that they are actually random. Take this bit:

(SNIP)I create a new simple model
like a wine glass, attached bones.
Create a new animation, create a
new Choreography, import created
model, import created animation,
they try to do something and A:M

Look at it from Hash's point of view - "try to do something and them AM dissapears" isn't very precise. Here's what I did recently to nail down an elusive bug. It might work for you.

Create your object as usual, but save it as a seperate model, not embedded in the project. Then, every time you modify it or add a bone or delete a bone, hit CONTROL-S to save the project (which will also save the object seperately). Keep doing this till you get a crash (for me, it was deleting any bone three layers deep in a heirachy in an object created in v9.51e being edited in v10b).

Once it crashes, start a NEW project, and load in the object. Nothing else. Try doing whatever it was that caused the crash again. If you're "lucky", AM will crash again. Try it a few times. If it keeps crashing every time, then you've got yourself a nice repeatable bug - just email the object alone to Steve, with the steps necessary to make AM crash, and either Steve's copy will crash too, or you'll at least be closer to knowing what's going on.

Also, make sure you have the latest version/s - you weren't quite clear in your post with naming the versions. The last 9.5 release was 9.51e as far as I know. v10 is up to v10c.

It's frustrating to have to nail down random bugs in order to be taken seriously, but I don't see any other way. On the other hand, if LOTS of people started reporting, say, random hard-to-repeat but bone-related crashing, I'm sure Hash would look into it. So report early and report often!

Oh, and the bug I mentioned above has been acknowledged by Hash, but only seems to affect models created in v9.51e that are being editied in v10b/c. So not exactly a high-profile bug, but there all the same - who knows what other odd behaviours this error might cause that get fixed when this bug is fixed? :)

01 January 2003, 09:58 PM
Thanks for the suggestions on reporting more precise steps to reproduct bugs.

The version that I was on at the time of reporting the bug was 9.5z (which was the latest at the time). It also crashed at the time of reporting with the Beta version of 10. I do not remember what version it was at time of reporting for the Beta 10.

I now have version 9.51e, the latest for the 9.x version. I did not upgrade to version 10 because I keep crashing and/or A:M dissapear on me with all of the Beta 10 version. I just could not justify upgrading, and I am still unsure at this time.

01 January 2003, 10:21 PM
So, does v9.51e have the same problem? Or is it OK?

01 January 2003, 10:45 PM
Below are the exact steps I did to reproduce error in 9.51e with same results, on the last step when I right clicked on the Path I just created, A:M just dissapeared and closed without warning.

1. Create a line with about 10 points, then Revolve (Shape of Wine Glass)
2. Create bones and assign bones.
3. Create New Simple Action of 00:02:00 long.
4. Create a New Choriagraphy, got to top view, create a path of 3 points. Select it then right click on path and A:M Dissapeared.

Usually I could get further and import the Wine Glass just created, attachet to the path, right click on the Wine Glass object, try to attach the Action just created and A:M would dissapear.

01 January 2003, 10:48 PM

These are the steps that I emaild to Hash Support with my support email, sorry for not posting it with my original post. As you can see, A:M Dissapears or Crashes in different points.

First Try and crash
1. File, New Model
2. Added a 9 point sline.
3. Selected bottim point, then clicked on the Lathe
4. Switteched to Perspective view and clicked on Render Mode.
5. File, New Action
6. Clicked on button Render Mode, then moved mouse on render area, right clicked and A:m Crashed. Error file attached.

Closed A:M, started again
2nd Try and crash
1. File, New Model
2. Added a 9 point sline.
3. Selected bottim point, then clicked on the Lathe
4. Switteched to Perspective view and clicked on Render Mode.
5. File, New Action
6. Clicked on button Render Mode, then moved mouse on render area, right clicked and A:m Crashed. Error file attached.
7. Key framed (Only in filtered channels that pre-exist) at 00:05:00 Chalice bending left
8. Key framed at 00:08:00 Chalice bending right
9. Key framed at 00:10:00 Pasted Keyframe from frame 00:00:00
10. File, New Choreography
11. Switched to Top View and added a path with 7 points
12. Right clicked, Imported Model1 that I just created.
13. Right clicked on Model1, New Constraint Path
14. Right clicked on Model1, Imported Action I created for Model1
15. clicked on Model1, in the Time Line, clicked on Action1, clicked on Delete Key and A:M crashed

01 January 2003, 09:08 AM
Did you save the wine glass as a seperate object? What happens when you start a NEW project, load in the glass, make a path, and right click? Same crash? Apart from anything else, it saves having to create the glass every time...

By saving the object out, it means Steve, and anyone else, can test the issue with the exact same model. Send the model to me if you want me to try it. Better still, save the whole choreography, path and all, BEFORE you right click on the path! Then we'll see what we can see.

01 January 2003, 04:59 PM
I will try to save the project before crashing, but here is the problem:

As you can see, I posted 3 different cases where A:M just dissapears, and on another thread, another different bug. It does not always crash in the same step, but if you follow either one, A:M will dissapear at once.

01 January 2003, 05:33 PM
Steve is right is his analysis of the problem. It does sound like a video processor malfunction or driver issue.

1. MFC42.DLL translates all of the video related mouse actions. This file can be altered by installing old or other graphically intensive software with it's own customized MFC42.DLL.
2. Motherboard bios and AGP processors can malfunction with the wrong hardware drivers and bus speeds as well. Too, an insufficient or noisy power supply can cause strange problems.

My story:
I once owned a pro motherboard that had a programmed bug in the AGP hardware that caused a memory leak. The ATI Radeon 8500 (with it's poorly crafted OpenGL drivers) would freek out.
This computer was doing about the same thing as yours, but it would pause after a render. Refresh the screen - select a CP and A:M would freeze.
ATI has really buggy OpenGL drivers. So it was really difficult to nail down the root cause of the problem because of all the varibles.

Fixed: (A:M v9.5e is fairly happy) :cool:
Purchased a new MB and MSI NVidia Gforce4 fixed the basic A:M stability issues. A:M still crashes, but usually when doing experimental constraint stuff, distorts and various experimental muscle motions (still learning). Nested [Translate to] constraints with compensate on and lag seems to be my number one crasher.

01 January 2003, 05:46 PM
I disagree that the video card is the issue.

I have tried this with 4 different computers, with different video cards. I cannot see the Video cards to be the issue. I even tried on someones comuter that they use for professional 3D work and A:M dissapeared on that one too. There is a problem with the softare not the hardware? My other 3D software programs that Iam trying out do not crash like this.

I just got a new computer, Pentium 4, 1 Gb of RAM, 80 Gig of hard drive space, the latest NVIDIA GeForce Ti 4200. I have Reformated computers with the latest Windows XP Professional, all of the latest drives, but the results are the same.

01 January 2003, 05:47 PM

I went to ComDex last year and went to the Hash boot. I stayed for about 4-5 demos. And during their demos, A:M would crash and the Hasp person would say that it was the lack of his video card?????? I do not think so.

01 January 2003, 04:33 PM
Sorry if I wasn't clear in my last post. I was suggesting you save the project as you go - trying to save just before a random crash is impossible! :)

After every thing you do, hit CNTRL-S. Then, when AM crashes, load that project. See if it crashes again when you do the same thing. If not, then you've got yourself a random bug. Yuk. If it does crash every time, send it to Hash!

Either way send me the file and I'll be happy to test it here. After all, if it doesn't crash here then it might be a bug that's specific to your system (not saying it's your system's fault, the bug might be in AM, just saying that the bug might only rise up on your system).

01 January 2003, 07:14 PM
Ok. I wil try to do so.

I have a feeling that its a random bug because so far A:M does not dissapear in the same step, its usually differen, but it does dissapear by following the steps posted.

CGTalk Moderation
01 January 2006, 07:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.