View Full Version : Texture map mystery?

07-13-2006, 07:25 AM
I'm new to this. Can somebody please explain to me what I've done wrong with the texture mapping of this ship?

07-13-2006, 08:26 AM
Hi Gekko_One,
Well, I think first of all you're going to have to give us a little more to go on. At the moment I have no idea; what it's supposed to look like when textured correctly, what the textures look like by themselves, how you are trying to map the image to the object and just about everything else. But don't worry, I've no doubt that its something quite simple. Well, I hope it is.
At a guess, it looks like you have 3 surfaces on your object (the orange green and purple). The two engine things look like they need clindrical mapping along the x or z axis, then make sure to autosize the texture so that it fits correctly.
The vertical hull part (orange) looks like it need cylindrical mapping too, but on the y axis. Again, select autosize.

If that's not the solution you'll have to provide more information, but good luck.

07-14-2006, 06:14 AM
Thanks for trying to help me out Luke, much appreciated. Here's what the ship looks like with no texture maps.
Here's the engine pod texture map. (They're quite rough at the moment as I'm trying to learn how to do this so didn't want to spend too much time on them yet).
Here is the view in Lightwave
And here is the rendered result? Engine pods were cylindrically mapped along the Z axis and auto sized.
Any clues?



07-14-2006, 02:32 PM
maybe doubled geometry. as a test load up the model im modeler, select a polygon in
the orange colored area, then hit the minus key to 'hide' it. if the polygon still apears to be there after you fo that theres doubled geometry.

- Will.

07-14-2006, 02:49 PM
Hi Will,

just tried what you suggested. Polygon disappeared every time on all surfaces I tried it on.




07-14-2006, 04:55 PM
Hmm. try selecting a poly then push i. if two polygons are listed, thats the problem...

also check to see if you might accidentally have any 'hidden' geometry by pushing the
\ key.

beyond that, the only thing i can think of is the basics. perhaps try tripling the geometry (save your original as a dif file name so you can go back). Check for 2 point polygons.
try rendering it subpatched/unsubpatched. check to see that Double Sided Polygons
is off in the surface editor maybe. Check the Advanced tab on the texture to see if you've got something like Color Highlites or Diffuse Sharpness on....

check to see if you have any edge rendering things turned on on the EDGES tab on the
object properties.

worse comes to worse, cut off one of the engine pods or something and maybe post it here for people to take a look at.

and in the end, Sadly, try rebuilding it from scratch - it seems a fairly simple object so hopefully if you do have to go that route it shouldnt be too bad....

- Will.

07-14-2006, 05:11 PM
An alpha in the image map perhaps.

07-15-2006, 12:24 PM
Your not going to believe it guys, I've accidentally worked out what I was doing wrong!

I was using .psd maps instead of .jpg maps!

Thanks for all your help anyway much appreciated.



07-16-2006, 09:44 PM

Glad you solved your problem :thumbsup: . Anyway, there is another reason that could make you face that kind of problem. In the texture menu, check the Heigth Tile and Width Tile dropdown menus : you may have something wrong with them (like "reset" or "edge" that could make strange looking results when it's not what you wanted it to be).

Be well :)

07-16-2006, 10:19 PM
heh. sometimes its the Simplest things!

- Will.

CGTalk Moderation
07-16-2006, 10:19 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.