View Full Version : Using Visual C++ Express with sdk?

06 June 2006, 07:47 PM

Anyone got any info on how to use Visual C++ Express with the 9.6 SDK?

Iv'e tried in the past without success, and today as I decided to format, I felt I could have another go at using VC Express on a nice new fresh install of Cinema4D... yet again without success (with the usual 100's of errors)

I know of at least two people who have managed to compile the SDK just fine (from plugincafe), so I know its possible.

Anyone else had issues and solved them?


06 June 2006, 09:03 PM
VC Express works just fine (it's what most plugin developers use), and the SDK works straight out of thebox with it... when it's fully installed that is. The issue you may be facing is that MS do not give you the full thing when you actually download it. You must additionally download the "Platform SDK" and install that:

After you are fully and properly installed you should then just open the Cinema SDK project, hitting compile should result in a build straight out of the box wiht no errors.

06 June 2006, 11:25 PM
Is it possible that the api libraries are not being found. Make sure you open the file named cinema4dsdk.sln and not the cinema4dsdk.vcproj, which is not the only project integrated into the solution. The other one is for the api libraries and resides in the resource\_api_lib folder of you c4d installation.


06 June 2006, 12:30 AM
actually when you first open the SDK folder i don't think there is a .sln file yet, you should pick the one with the nice big simple icon that's the cinema4dsdk.dsw file. just double clicking on that will launch VC++ and then it iwll guide you through the rest of the importing process (you just say yes when it asks you if you want to update from VC6). from then on as JDP said, you use the newer cinema4dsdk.sln file.

06 June 2006, 05:52 PM
I didnt know about the Platform SDK until AFTER I tried to open and compile the SDK, I think thats the reason why I am gettings lots of errors. Perhaps the original build attempt broke something.

I will re-install C4D and try again

Thanks for the help

CGTalk Moderation
06 June 2006, 05:52 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.