View Full Version : coffee ignored when rendering

05 May 2006, 07:52 PM
Hi there! Im hoping someone here can help...

Ive an xpresso tag with a c.o.f.f.e.e. node inside it. It reads data from a file and applies it to objects within my scene. (In the example provided, it plays a test video I made on one of those toys made with lots of pins. To get the example to work, just unpack the file, load the c4d file up and select the `Data Streamer` object - you just need to alter the path of the `base filename` setting to point it to where the `videotest1` folder that is also in the archive, remembering to keep the `\frame` bit at the end.

Anyway - it works in the editor fine. If you swap between frames in the timeline, different frames of animation apply to the pin objects and all works - great. However, when you RENDER the project out as an animation, even though the c.o.f.f.e.e. executes, reads the relevant data, applies it, the object state in the render is always the current frame that was in the editor when you started the render.

Even stranger, if you add a EventAdd() into the c.o.f.f.e.e. so everything gets updated every time the next frame is rendered - you can see in the editor, the objects are all updated fine - but in the render window, it STILL doesnt change!

Weve tried sending ->message(), ->multimessage(), changing the priority the xpresso node runs at, all sorts of things. Always works in the editor - but not when rendering. (Preview render has the same problem too).

Does anyone have any ideas? Were completely stuck!

Many thanks in advance


for a frend, coz he cant wait the time to get this topic approved :D

05 May 2006, 07:53 PM
many thanks for posting for me angelus :D


05 May 2006, 08:10 PM
Sound very familiar to a problem I had in the beginning of my coffee adventures.

What happens when Cinema renders, is that a complete copy of your scene is done for render. This is good since then you can still work on your scene while render.

The solution in my case (a coffee expression plugin tag) was to add code so it gets included in the rendering.

How that code could be implemented in a xpresso coffe node, Im not sure but here it is.

var tag = obj->GetFirstTag();
if (tag->GetType() == type)
return tag;
tag = tag->GetNext()
return NULL

It might help you.


05 May 2006, 08:37 PM
Na, It might not be it.

I tried the scene on my Mac and nothing happens. There is a "Sorry Mac" note in the code.

There is a Material player originaly done by AG over at
It finds and reads pictseries from a tex folder. It might be some usefull info in that coffe code.

Go to:

and then , xfiles RTEv2.


05 May 2006, 10:31 PM
No luck yet!

Ive tried converting my coffee node into a coffee tag - but then opening a file (basefile->open) wont work. Works in the node ok. Im sure i remember reading file operations dont work in a coffee tag (incase of virus risk or something silly)

Any ideas/confirmation of that?

many thanks


05 May 2006, 01:00 PM

Ive still got the same problem (works in editor but not in render) and I just cant fix it.
Ive tried using the getfirsttag() method listed above. (I ported my code into a expressiontagplugin, and (when c4d decides its in the mood to run it) it did work. But not from within my coffee node.

Ive also tried searching for objects and their tags using different methods, specifying them hardcoded by hand, you name it (to simulate the getfirsttag solution above in other forms)

Ive tried putting userdata items on my xpresso tag, on the object that contains the xpresso tag, hardcoding my values into variables inside the code, passing my userdata items in via xpresso.

All methods work for getting my data into my coffee - lots of println()'s show the data its processing on is fine, file names of files im reading are fine, the values being processed are fine.

But..... Nothing! Always works in the editor - not the renderer.

Note: I want this to be run specifically from inside c4d - not from a plugin. And I cant run it from a coffee tag as they dont support the file operations (really suprises me the file reading limitations in a cofee tag)

Does anyone have any ideas? Im all out :( :( :(

Many thanks


11 November 2006, 07:37 AM
i have the same problem with my xpresso / coffee node "animated matrix extrude" solution. i am in r8.2 and it animates just fine in the editor, but the render output is exactly as described above.

has there been a solution to this problem???

11 November 2006, 04:35 PM
i got it working in the end, was a pain in the arse, give me an email ( and ill dig out the project I made and pass it over

martin :)

CGTalk Moderation
11 November 2006, 04:35 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.