View Full Version : HDRI render with FG & GI turns everything to iluminated!

04 April 2006, 11:26 PM

this are my first steps in lighting and rendering, i want to set up a HDRI for have nice reflections on a surface, and i do get nice reflection on the surface, the problem is that i have no control over the lights that i had in my scene and everything turns to white and iluminated.
I know that loading an image in to the "image base lighting" acts as a light and reflection source....right?.....and that`s good when i want some nice relections and highlights in some surfaces...

here is a very basic example just to show what i mean

default render in MR with out Final Gather and Global ilumination, with two point lights with ray Trace shadows on

the same render but with HDRI load in to "image base lighting", with FG turn on and also GI, but with no caustics.....i turn to 8 the filter in the FG section...and still with the 2 same lights,

and lastly here is the same example but i delete the lights...the problem is that i lost completely the kind of lighting that i was looking for...

is there a way to have nice reflection on the spheres and maintain some of the original lighting and have more control in the overall lighting?

thanks in advance

Best regards

04 April 2006, 11:59 PM
You can just set the IBL node to not be visible to FG rays, or to not emit light, or tweak its intensity (don't know what way you're doing it, exactly) -- it's in the IBL node settings. Fiddle around in there.

04 April 2006, 11:59 PM
To have more control with the HDRI solution, the Colour Gain slider will control the brightness of the HDRI map. You should also have a look a the render stats section, and play with visible in Final Gather check box to keep your nice reflections, but have no FG calculated for the HDRI map.

Of course, the best solution is to render out each light in its own layer and comp in post...hence complete control.

04 April 2006, 01:50 AM
thanks guys, now the other objects in the scene are not afected by the HDRI, the problem that i have now is that the spheres are not receiving cast shadows and are not also being afected by the lights....

look this render that i made in made with the eye that i found in here:;action=display;threadid=24731

Since i don`t know very much XSI, i just open the scene and move some lights around and i put a polygon object to cast some shadows....note that the eye is receiving light and shadow and still mantain a nice reflection on it...and the reflection reacts as well to the light that i position..

that is what i want to make in maya, nice reflection but complete control over the lighting and shadows...well, the only problem that i have now in maya is that the sphere is not receiving any shadow and is not being afected by the almost like if it where independent from the other objects in the scene....

please what can i do?


04 April 2006, 01:57 AM
Check your render stats in the shape node. You probably have "recieve shadows" ticked to off.

04 April 2006, 03:33 AM
Check your render stats in the shape node. You probably have "recieve shadows" ticked to off.

thanks a lot for your help...

here is a very basic scene in maya to show what i`m saying..

first i made two spheres, i made one a little bit biger and transparent...then i created a point light with cast shadow...and render with default render

then i upload an HDR image in the image base lighting tab, i turn on FG and GI, and i uncheck "primary visibility" and "visible in final gather"...i live enable default lights in the RS on.

And i uncheck cast shadows and receive shadows....i thought that when was uncheked it meant off and with check it mean on...but hear it seems that is not like that..

how can i make the cast shadows more strong and dark?...i already turn the filter in the FG to 4...

thanks again for the help

best regards

04 April 2006, 02:48 PM
You can just set the IBL node to not be visible to FG rays, or to not emit light,

how can i set the IBL node to not be visible to FG rays?..or to not emit light? it the same thing to adjust the color gain for brightness intensity..?


04 April 2006, 10:42 PM
First of all, you should check back on the "Cast shadows" and "Receive shadows" in the sphereShape node. They actually mean ON when they're checked!

You already set the IBL not to take part in FG when you unchecked "Visible In Final Gather" under IblShape node > Render stats. It's not the same thing to adjust the Color gain, because changing the color gain you wil also change the intensity of the reflections, but you want to keep the reflections, right?!

Another thing... Maybe you don't need FG in your scene. At least it looks like you only want to use direct lights and get the reflections from the IBL node. If that's the case, turn FG off.
About the FG filter, it's not recommended to use it higher then 3 or 4.

Good luck.

04 April 2006, 01:38 AM
thanks Kako...great information, i`m goin to check all that.


CGTalk Moderation
04 April 2006, 01:38 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.