View Full Version : Mayatomr translation crash

04-13-2006, 06:43 PM
Hey all,

I am using MR standalone, and rendering a shot with a TON of fur. We're at 4 million hairs now, and want to push it to something like 10-12. Sadly, Mayatomr seems to crap out once we get past 4 million hairs.

At its most verbose setting, it's printing out what line it's on when it's translating the fur to MR primitives in a temporary .mi render file. Then, around line 15000000, it dies. You have something like this:

MI 0.0 progr: file c:/temp/ginn_sc03_08_jp_0014.mi line 14800000
MI 0.0 progr: file c:/temp/ginn_sc03_08_jp_0014.mi line 14850000
MI 0.0 progr: file c:/temp/ginn_sc03_08_jp_0014.mi line 14900000
MI 0.0 error: 121001: c:/temp/ginn_sc03_08_jp_0014.mi, line 14934231: while defining object "|FurFeedback|BAKED_ORIGINAL_cloth2_FurFeedback|BAKED_ORIGINAL_cloth2_FurFeedbackShape": syntax error

Of course, then, it deletes the temporary .mi file, so I can't take a look at it and tell what the error is. I tried exporting a .mi file locally to take a look at it, but it ended up being 2.5 gigs, and I can't open it in a text editor.

I've tried tiling the render, to no avail. It doesn't even get to Mental Ray, so BSP settings and physical memory settings aren't really helping. Suggestions would be appreciated.

CGTalk Moderation
04-13-2006, 06:43 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.