View Full Version : render layer pass alpha issue

03-22-2006, 07:38 PM
I apologize for the somewhat nonsensical title, but I am totally baffled. So I had a project I had bulit in Maya 6, had set up a few render layers, and then I installed Maya 7. First issue. Nothing appears in the master layer. So I figure, oh well, and I set up my render layers. Well now I am getting massively frustrated by these layers. I set up separate layers for diffuse and specular because the documentation said it prefers that, but now suddenly I have a materal that was supposed to be transparent, and it always was in Maya 6, but now suddenly in Maya 7, the diffuse pass makes it look solid, but when you flip to the alpha, the transparency is there, but it doesn't account for any of the geometry behind it. A magical alpha hole, if you will.

Am I completely psychotic? Am I just totally missing something???

Thank you in advance for any ideas.

03-23-2006, 03:18 AM
I don't have 7 and I haven't used its render layers, but I know from compositing that layering different light passes for a transparent object can be very tedious and sometimes impossible. Especially when you can see the back of the object through the front. I would say just set it up however you want to composite them, not how maya "prefers." With the transparent object, begin with a full color pass and just get the transparency right. Then start breaking out the layers if you really need the control during post processing.

Also check the render layers documentation for anything about layering transparent objects.

03-23-2006, 03:35 PM
Thank you kindly for your response. You are correct about transparency renders... it is quite.... painful.... and try as I might, the documentation had said very little. Hence my desperate post.

Oddly enough, last night in my frustration I did a lot of tedious troubleshooting. I ended up importing the whole old scene into a new scene, redid the render layers, and voila it worked. I think it did not love the fact that the geometry wasn't in the master layer. I still don't get why the geometry refused to be in the master layer after I upgraded to 7.0, but I am not going to argue with it. It is now fine.

As for the layers... I did try to still set them up how I wanted, ticking off "diffuse" and "specular" in the render layers options, and it just renders one image right over the other. It seems to demand that I have a separate render layer for each pass using their preset passes. Since I am under a deadline crunch (surprise,) I will bow to the Maya gods and just do it.

CGTalk Moderation
03-23-2006, 03:35 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.