View Full Version : Why are my UV's not being created properly? Help!

03 March 2006, 08:47 PM
I'm trying to get to grips with LW's UV texturing but I don't understand why my UV's are turning out the way they are?

Here is a image, all I'm doing is selecting some polys and applying a cylindrical map to them around the Y.

I don't understand why there is a big gap in my uv map? Presumably it's because I need to rotate the mapping coordinates but how do I do this? I want the left portion of the map to be attached to the right part, as the arrow indicates. If I try to move the portion a vertex is always pinned at the corners.

Every tutorial I've seen doesn't cover this. They always map perfectly, ie no gap.

Any help greatly appreciated.

03 March 2006, 09:17 PM
(I think) it is because you do not have your object centered. Make a morph and center it if you need to keep the objects position.

Also Unweld the polys to move the corner points in the UV map. Then merge when you are done.

03 March 2006, 09:30 PM
From the looks of your image you don't have all the polys on the cylinder selected. The gap in your mesh is because of the gap in your selection.

If it was your intent to only uv map part of the cylinder with this selection then you can unweld the selected polys and in the UV view select and move one group of polys to line up with the other. Merge points when you've got things lined up the way you want.

03 March 2006, 09:58 PM
Thanks for the replies guys.

This is what I don't understand, I've been following this tutorial here ( and as you can see neither is it centered nor is the whole object selected when UV's are applied.

I've been unwielding my polys also but I still can't move some of my corner points!?

03 March 2006, 10:14 PM
There's something very odd going on here...

I've tried reversing the selection I apply the UV's to. SO I select the polys start from the left this time and the UV map looks exactly correct, no gap!?

Why is this?

An even bigger worry is in the tutorial I've been following the model in my LW isn't orientated in the same direction as the tut!!?? So my models feet are pointing down the +Z but in the tut it looks like their models feet are pointing doen the -Z!??

Whats going on!? Could someone do me a huge favor and download the tuts model and load it up in their LW to see which way its pointing?

03 March 2006, 10:36 PM
that tutorial never made sense to me. If you have a cylinder. why not UV the whole object? that makes a perfect UV Map.

If you want to map half of it, then do a planar map down the X.



03 March 2006, 10:52 PM
Urgh this is driving me nuts.

IZZE, I know it doesn't make sense but I can see points where it would be useful. Why does it work when I select polys from one side and not the other!?

Also I've tried a test where I create a cylinder delete the top and bottom and then unweld all the polys. I then apply a cylindrical UV map to it and it appears fine. However when I come to move the map itself in the uv texture window 2 points are always pinned!? Is this supposed to happen? I thought if you unwielded the polys this should not happen?

How am I supposed to move my polys around to create a logical texture page!?

03 March 2006, 11:08 PM
I'm not going to sound very smart here but, it looks like when creating a Cyndricial map it starts on the -X axis then works outwards from there. going -X + +Z, then goes -X + -Z, then back to -X + +Z again. repeat.

so when selecting the polys all on the -X side of my Z plane it starts by finding a poly. when selecting only the polys on the +X side of my Z plane it starts by finding empty space.

Gosh that sounds stupid. hope someone can explain it better.

I dont know why you have points you cant move. I dont have that issue.

03 March 2006, 11:21 PM
Thanks for your help with this IZZE.

I'm not quite sure I understand your explanation but on the subject of the vertices being pinned...

Are you saying that if you create a cylinder, unweld it, apply cylindrical UVs and then move the map; it would move completely without any vertices being pinned?

This is a image of what I get when I do this.

Is this supposed to happen or not? :(

03 March 2006, 11:26 PM
nah. make the UV then unweld.

My last post was wrong. the last part of my "equation" was supposed to be a +Z. I've changed it

03 March 2006, 11:38 PM
It's still doing the same thing...! :( One side is always pinned.

Definitively, can you do this with your copy of LW?

03 March 2006, 11:43 PM
I dont have this problem with any versions of lightwave. I think you might have symmetry on.

03 March 2006, 11:51 PM
This is very odd. I've discovered that if I unwield TWICE, I'm able to move the whole UV's finally...!???

I've checked if I'm creating anymore verts by unwielding twice but I'm not?

Why the hell would it need me to do this twice and not other people?

BTW I didn't have Symmetry on.

03 March 2006, 12:32 AM
If you're using LW 8.5 launch the help system (Help> Contents) and scroll down to the tutorials. There are a bunch of excellent UV mapping tutorials that walk you from simple to complex mapping.

CGTalk Moderation
03 March 2006, 12:32 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.