View Full Version : mental ray sattellite cant batch render

02 February 2006, 11:33 AM
Hi, i have just installed mr satteliite for maya 7 on my slave machine tonight. followed the instructions from the doc, now the problem is that maya can only network render 1 frame (which using the render->render current frame option), when i do batch render, it will only render on my master machine. i have even tried to switch on and off the "render on this machine" option, no luck.
it looks from the script editor, maya only reads my maya.rayhost file when i do "render current frame", and not reading this file at all when doing "batch render".

2 more questions:
1. do i even need to install sattellite on my master machine as well?
2. what do all those 3rd party render management software do? what kinda benifits do i gain? should i consider install one if i only have 1 master and 1 slave at the moment?


02 February 2006, 02:33 PM
I've never had any problems with rendering batches with satellite. I have found, however, that it only checks the rayhosts the first time you use MR from maya. Maybe all you need is to restart Maya, and you'll be good?

1. No. Satellite is only on the slave machines.
2. Third party render controllers are great, even if you don't have *any* satellites, because you can queue and prioritize your renders, without writing batch scripts, and have a much smaller memory footprint than running the Maya GUI, so renders that push memory limits are a bit larger.

02 February 2006, 03:45 PM
thank you the answers. i will keep trying

02 February 2006, 05:35 PM
nessus - What aere you getting in the output window whenyou try and batch? MR should check the rayhosts file either way (batch or single). In the MR preferences set it to output the progress messages. This will give you feedback on what each machine is doing as the render progresses.

02 February 2006, 08:51 PM
script editor outputs for render single (current) frame:// Info: (mental ray) : loading startup file: C:/Program Files/Alias/Maya7.0/mentalray/maya.rayrc
// mental ray for Maya: using rayhosts file C:/Documents and Settings/nessus/My Documents/maya/7.0/prefs//maya.rayhosts
// Info: (mental ray) : adding rayhosts
// Info: (mental ray) : adding host:
// Info: (mental ray) : number of render thread(s): 4
// Info: (mental ray) : network rendering slaves:
// Info: (Mayatomr.Scene) : shadows obey light linking requires full shadow tracing, optimize raytrace shadows ignored
// Info: (Mayatomr.Nodes) : derive mental ray global approximation settings from Maya
// Info: (Mayatomr.Nodes) : derive mental ray global displacement settings from Maya
// Info: (Mayatomr.Scene) : update lights and related shaders
// Info: (Mayatomr.Scene) : update cameras and related shaders
// Info: (Mayatomr.Scene) : saving image to file D:/Work/VFS/network_render/test/images/tmp/test.001
// Info: (Mayatomr.Scene) : update geometry and materials
// Info: (Mayatomr.Scene) : render camera: persp

output for batch render:
Image name is now test
// Result: saving temporary file D:/Work/VFS/network_render/test/scenes/test__4080.mb //
// Result: Rendering with mental ray... //
// Result: Percentage of rendering done: 0 (D:/Work/VFS/network_render/test/images/test.001) //
// Result: Percentage of rendering done: 5 (D:/Work/VFS/network_render/test/images/test.001) //
// Result: Percentage of rendering done: 10 (D:/Work/VFS/network_render/test/images/test.001) //
// Result: Percentage of rendering done: 15 (D:/Work/VFS/network_render/test/images/test.001) //
// Result: Render Cancelled. //

as you can see in the single output, maya is reading the maya.rayhosts file, and is the slave machine. at least its reading the file.

second output is batch render. it goes directly into render. i even unchecked the "render on this machine" option. so its not reading the file.

besides all the trouble, i have also noticed that there is not much of control in terms of monitoring the process of rendering. so even i could get all this setup and working, the only place i can actually see the usage of rendering on my master and slave machines are through the script editor? will it actually show the rendering process on the slave machines from the master machines script editor, assuming i have everything properly setup

08 August 2006, 12:28 AM
hey guys,

im having the same issue. i when i render in maya by choosing "render current frame" or using the Mayatomr -pr mel comand everything is fine and my renders go to my 8 slave computers. but when i try to batch render it only goes on my comptuer, whether i have "render on this computer" checked or not.
anyone have same issues? figure out how to fix it?

08 August 2006, 05:20 PM
I had problems with renders stopping with no reason if the master workstation was used in a satellite render. I ended up setting up my batch commandlne renders with the flag -nmr 1 to turn off rendering by the master computer. I still get screwups by satellite if a node "hiccups". Satellite is too stupid to continue on with a render if a node drops in the middle of a frame, and with satellite node drops seem to happen at least once a day. It suck to come in the next day and find only 49 frames of a 1000+ render done because Satellite is crap.

08 August 2006, 06:30 AM
Does satellite work now in Maya 7 ?
I used to work with satellite a lot in Maya 6.5 and it worked really well. But with Maya7 i can not make it work. In other posts i read that i has a bug ?

08 August 2006, 12:10 PM
were u able to fix ur problem nessus. I am having similar trouble-

Have 2 PCs
Installed MR satellite on the slave and the master has Maya 7 installed.
Edited the .rayhosts file on master with the name of the slave and port no.(

The services file for winXP on the slave machine lists these-

mi-ray 7003/tcp
mi-raysat 7105/tcp
mi-raysat345 7104/tcp

I am using a simple test scene with a sphere moving around for 24 frames.

i tried both command line and batch render.

The progress mssgs show evertything is being rendered on the master machine only. Though there is network activity and the slave machine also fires up raysat345.exe service whenever a render is issued on the master but does no rendering actually.

i also tried a scene from my projects with MR shaders etc. It was doing the same thing.

dont understand wats goin on....any help guys?

CGTalk Moderation
08 August 2006, 12:10 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.