View Full Version : Caustics Render Element

02 February 2006, 11:23 AM
Hi guys,

Any chance there is a way to easily composite caustics? Im using mental ray, although a vray tip would also be greatly appreciated.

Just to clarify, I have an exterior scene which I want light to bounce off water and hit a wall. The original scene is rendered, and all I need is to add caustics for dramatic effect.

If I find a solution I will write a nice tutorial.


02 February 2006, 01:31 AM
i am having the same situation.

i tried the render layer option, but it only works with shadows (this is the only information kept from the ghosted object) but when it comes to photons, they ignore the presence of a ghosted object and the continu in space.

02 February 2006, 01:38 PM
Same exact problem... MR guru's where are you :)

02 February 2006, 05:05 PM
I don't know which package you guys are using, but here's how to create a Mental Ray caustics pass in XSI (other than simply clicking New Pass -> Caustics of course):

It's actually quite simple. Once you have set up your scene with caustics, you just need to create a couple of partitions to override some settings:

Lights that don't cast caustics: Override light intensity to 0
Lights that cast caustics: Override light intensity to 0 (optional: overrides for photon amount / strength)

And that's basically it. With the light intensities set to 0 all you're gonna get is the caustic photons.

Of course, for better control on the pass level you'd ideally also set up partitions for caustic transmitting objects and for caustic receiving objects and override their transmit/receive settings on the pass level.

But once again, I don't know which package you are using and how passes are set up in it, so I hope this helped.

02 February 2006, 12:45 AM
I am using 3ds Max. Setting the light multiplier to 0 doesnt not product caustics.
Sounds logical enough.. but I dont think it works in 3ds max.

02 February 2006, 09:43 AM
I have a small tut on caustic for 3Ds and Mental ray, if I remember well you have to select the object creating caustic and right click to select propierties, there you can enable caustic.

if you then go to the renderer options in advanced light you have the enable caustic options.

I remember that to have a very nice effect it was good to use the mental ray material

in the diffuse slot put a mental ray Glass and as well in the shadow (and change transparency as you want a very small shadow). then lower you have a photoon control slot and there you can set the photon basic mental ray material changing as well the transparency so that you can see them a bit reflecting on the surrounding area.

I don't have Max in fron of me, if you have a bit of patient I will post it tonight when back home ( +- 9 hours from now..)


02 February 2006, 03:40 PM
If you can't get the light emitting caustic photons to work with black for the light color or with 0 for the multiplier, then leave the intensity and multiplier in whatever settings that work, and make a 2nd copy of that light. The 2nd copy should not emit caustic photons, and it should have a negative multiplier (like -1 if the first light's multiplier was 1), but otherwise it should have all the same settings, so it just removes any direct illumination - then all you have is the caustic illumination.


02 February 2006, 12:32 PM
very sneaky :) thanks for that tip I will try it.

I keep forgetting negative light and how usefull it is :)

Thanks again.

02 February 2006, 03:11 AM
Yes, thank you. That negative light trick is indeed a reminder of something very useful as a last resort!


02 February 2006, 05:48 PM
Hello There just few days ago i was trying to do the same thing. ( i think?!) and the trick was to turn off the intesity of the lights but dont touch the photons.

CGTalk Moderation
02 February 2006, 05:48 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.