View Full Version : My alpha's not working, why?

02 February 2006, 11:37 PM
It's been so long since I did these things I can't recall now and I could certainly use some memory refreshing :wavey:

Ok, this is what I've done, have a look and let me know what I'm missing:
1. Imported a QuickTime file with a green screen already set.
2. Applyied Color Key Effect, and keyed out its green screen (which worked just fine).
3. exported to avi

On my 2nd attempt:
1. Went back to same project and added "Set Matte", without changing anything in the configuration

After each try, I would go back and import the created avi, put it in the timeline, and then put a still image under to confirm that the alpha was working.
Needless to say nothing has worked.
Can someone please enlighten me and tell me what am I doing wrong?

Thanks in advance,


02 February 2006, 12:03 AM
First of all, I highly recommend that you don't export to AVI, but instead render out to QuickTime Animation codec (under the Video Output, Format Options box) for best quality and ofcourse your color depth set to "Millions of Colors+"

Inorder to get an alpha channel with your render you need to make sure that the following Video Output menus are set like this:

Channel: RGB+Alpha
Depth: Millions of Color+
Color: Straight (Unmatted)*

*AfterEffects can work with Premultiplied (Matted) alphas but it prefers unmatted. A video or image render unmatted will look chunky if viewed by its self, but smooth without any black halo issues when imported and correctly interpreted into AfterEffects.

See the manual under "Interpret Footage" for more info.

02 February 2006, 03:11 AM
Cool, thank you so much SR :)

I found the settings you mentioned in the Render Queue/Output Module.
And, should I leave the Set Matte effect there?
This is how my effects list looks like:

Just out of curiousity, does AVI keep the alpha too?

Once the movie is made, do I still have to set it up in any especific way in AE in order to confirm it worked? I have been putting a still image under, but that's it. Maybe I should yet click or set something else?

Thanks again,


02 February 2006, 08:37 AM
No, definitely do not use the Set Matte effect. Its purpose is for something different. With that in mind, I'm assuming what you've been after is to key out the green (or blue) screen and render out footage with an alpha channel so you can import it back in without having to run the color key again. Correct?

If so, then follow my instructions. Forget about the Set Matte effect. Its not necessary. Once you got your green screen keyed out, render you clip out to a lossless compression codec such as quicktime animation. Forget about avi. Its a waste of your time.

Use the settings I suggested earlier for rendering out of AE with alpha, then reimport into AE and make sure in the interpret footage for alpha you chosse is straight unmatted.

In the Comp window, click on the white alpha chip button to check you alpha channel. If you get confused of what's where, then run the built in help and do a search for key words such as comp alpha or checker background. You'll need to figure out the Comp window buttons to show you what you want.

You're almost there.

02 February 2006, 09:26 AM
Like SirRender says - AVIs are mosstly useless for maintaining Alpah, bacause only few CoDEcs support that. Use Quicktime to maintain your Alpha.


02 February 2006, 11:41 PM
I never found that "white alpha chip button" but there is no need ;)
I guess removing that extra filter was enough :)

Thank you both so much for your help.


CGTalk Moderation
02 February 2006, 11:41 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.