View Full Version : Strange Blendshape problem - Any answers?

02 February 2006, 02:17 PM
Hi there,

Well, i've hit another snag in the on going saga of trying to rig my character. He's all bound, all the animation controls are in place and his body is moving and deforming nicely.

I created my blendshapes mesh's early on, before he was bound etc in the attempt to avoid any problems with stray verts moving about. But when i now apply the blendshapes there are 4 vertices on one shoulder that move down slightly.

Now the strange thing about it is that these 4 verts haven't been moved on any of the blendshape's i created. I've duplicated off a copy of my main mesh with everything in the history disable and i can line that up over any of the blendshapes and those 4 verts match up. I can even take this fresh copy of my mesh, apply it as a new blendshape back onto the main mesh and these 4 verts still move down. So i'm not even left with the option of making all my blendshapes again, as they're still going to have this problem.

I tried selecting those 4 verts and going into the component editor and dropping the blendshape weight for them. This seems to work for some of the blendshapes but on others it stops any verts moving about, so thats no good either.

I also tried making a corrective blendshape for the shoulder, which will work when 1 blendshape is set at 1, but as its a cumulative effect i'll have to be combining the total weight of all my blendshapes and applying it to the shoulderFix blendshape, which is abit of a headache but is the only option i can see at the minute.

Any help would be greatly appreciated, i've really struggled to setup this character 'correctly' and can't for the life of me figure this one out.


EDIT: I've tried changing the input order of the blendshape, before or after the skincluster etc. I've also disabled everyting in the history with just the blendshapes turned on and i still have the same problem.

02 February 2006, 11:07 AM
... but your problem seems to be one of those. I once had a similar problem with a simple character. Someone suggested that I triangulate the model and remake the blendshapes. That worked. The problem lied somewhere within the original model, and there was no reasonable way for me to go and find out about it.

Don't lose hope though - I'm by far NOT the most experienced dude here.

02 February 2006, 05:18 PM
I've kind of figured out what the problem is, but i don't know the correct way to fix it. After much searching through the hypergraph and turning on/off various things in the construction history, i realised a node called tweak11, and it has an envelope setting in the channel box. Now if i turn a blendshape up to 1, the dip appears in the shoulder, so i drop the tweak11 envelope to 0, the shoulder corrects itself. But as soon as i move a blendshape slider, the shoulder problem reappears. It doesn't make any difference if i set this node to 'Has No Effect'

I've gone through the hypdergraph and i can't delete this node, if i do, a new node appears called tweak12, then tweak13 etc, there is another node called DwarfOrigShape linked in there.

So i reckon the vertex movement has happened in there somewhere. Doesn't matter now, i ended up adding the opposite movement of the vertices onto each blendshape, there practically no movement now which i can live with.

Thanks for the suggestions

CGTalk Moderation
02 February 2006, 05:18 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.