View Full Version : Displacement Map Artifacts XSI to ZBrush HELP!

02 February 2006, 03:16 AM
Hey guys,

I'm having trouble with my displacement map when I import it from ZBrush into XSI. I seem to be getting some strange artifacts in my XSI renders of the finer details of my displacement map I made. From what I know I've followed the ZBrush to XSI displacement pipeline tutorial to the "T" and I'm still having trouble. I also got some great help from this thread here (

I've checked my UV's, there's no overlaps. When subdivding my model in ZBrush I divide to the highest level then do my detailing on the mesh. When I'm complete I go down to subdivision level 1, then I IMPORT my original OBJ to restore my model to it's orignal state. Then I export the model. Now I can make my displacement map. Settings as followed; ZSubPix 2, DPRes 4096, SmoothUV On, Mode ON.

After I make note of the alpha depth factor from the displacement map ZBrush just created. Load up "Displacement Exporter" Settings; D16, Status On, Vertical Flip YES. I then export my displacement map.

Now in XSI 5.0 I import my OBJ model I exported from Zbrush and attach the displacement map to it. I enter in my alpha depth factor as told. And check off "View Dependent Refinement".

At this point my model's displacement is a little too weak from what it was in Zbrush so I multiply the "New Range Start:" and "New Range End:" by 4. I also change the "Max Displ." to the same value in the geometry approximation setting as well. This makes my displacement more obvious.

So everything works great EXCEPT the fact that there's these tiny artifacts around the smaller details such as the mouth when I render in XSI.

Does anyone know what could be going wrong?? I've provided screens of what I'm talking about. Thanks guys!

XSI Artifacts:

ZBrush Model (what I want in XSI):


02 February 2006, 11:17 AM

the problem might be due to the uv space u gave the polys on the eyes and mouth arrea.

there is to much displacement information from zbrush and to less uvspace on ur map.

i think this is the problem. i had such artifacts as well. you could either paint neutral color
within photoshop on those arrea to smooth the artifacts (50% grey) or try to resize the
uv map on those parts

i hope it will help u


02 February 2006, 06:32 PM
I am sure you have already tried it, but if would suggest looking at your map in ps and seeing if there are dots there, and if there are try some other settings in the zbrush de exporter to try to get them out.

CGTalk Moderation
02 February 2006, 06:32 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.