View Full Version : After Effects error: opening sound component (-2166) Please help!

02 February 2006, 12:09 PM
I'm using AE5.5 and I'm trying to output my comp but each time I add audio to it I get this error message:

After Effects error: opening sound component (-2166)

(10 :: 44)

Can anyone tell me what the problem is here? I also get the same error when I load the audio into my comp and open its waveform?

The audio file is just a simple WAV file exported from Goldwave.

I'd really appreciate any help.

02 February 2006, 09:48 PM
I have had the same exact issue although it isn't as friendly as what you describe - usually AE just quits. My suggestion is to save your sound files as .aif - no compression. No other way around it. If you have problems saving it out as an .aif from goldwave use itunes to do it for you.

02 February 2006, 09:45 PM
I'm getting the same error with all the audio I try to export. I don't know what's causing it, but I've heard some people say that Quicktime 7 interferes with After Effects exporting so maybe that's the culprit.

02 February 2006, 07:55 PM
I've had the same problem today trying to render to both the DV codec and the AVID codec.

My solution (not really a fix) was to keep re-rendering the comp and hope it made it through the render...sometimes I get the error 4 frames in and sometimes it's almost done rendering...

I'm using AE 5.5 on I love how AE5.0 on OS9 was stable as hell...damn OSX....

I was experiencing something similar but not audio related back in September when I was using my custom render output templates. I had to manually click the output template, check the codec settings and just click all of the OK prompts and the render went fine.

As I type this, I've had 5 attempts fail at rendering a simple 30second!!! I think QT7 has to be part of the problem. I've never experienced this kind of stuff using OS9...good thing it's a dual-boot system and I can go back "home"....


02 February 2006, 09:15 AM
QT7 IS THE CULPRIT. This is a known issue, though not everyone experiences it.

It is not AE because the version I'm using (6.0) I've had for a couple of years with no changes whatsoever. Been working fine for all that time until I upgraded to QT7 a few months back. I even tried buying QT7 pro...but no go.

The ONLY solution i've found if you are having this trouble is to uninstall QT and install version 6.5.2 or earlier. I would like to stay on top of software updates, but I don't want to shell out the $$ for the newest version of AE unless this issue has been resolved on Macromedia's end. (even though it is a QT issue)

I get it with trying to preview or render to file - doesn't matter what type of audio is being used.

maybe we should build a database of info pertaining to this issue. I'll start:

System: Windows XP SP 2
CPU: AMD 2200+ (i know, it's ancient)
Video: nvidia 5900
Ram: 1 gig
QT version: 7.0.4 (just bought pro today)
AE 6.0

problem: After Effects error: opening sound component

02 February 2006, 10:19 AM
Yeah, QT 7 destroys any chance of rendering. I didnt like it anyway, so I installed qt6 and it works without problems now.

System: Windows XP Professional
CPU: AMD Athlon 1.5
Video: Radeon Sapphire 9200 Atlantis
Ram: 1 gig
QT version: 7 demo
AE 5

CGTalk Moderation
02 February 2006, 10:19 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.