View Full Version : Brush spontaneously turns into the eraser.

12 December 2005, 03:33 AM
I was wondering if anyone else has encountered this problem.

OSX 10.4.3
Intuos 3

I was getting this problem using Panther and It is still there on a different computer and a different tablet with different drivers.

What happens is that for no apparent reason my brush will suddenly become an eraser variant. I don't mean it acts like an eraser I mean the whole category changes.

It's spontaneous and unrepeatable and most annoying. Sometimes I'll open up Painter and the eraser will already be selected. In spite of the fact that I never use it.

12 December 2005, 07:34 AM

If you're using a Wacom tablet and your stylus is set up so the top end can be used as an Eraser, that might be the cause.

If you accidentally tap the tablet surface with the top end of your stylus, that will automatically select the Erasers brush category and the Eraser variant.

Check your Wacom Tablet Properties control panel, Tool Buttons tab to see if the top end of the stylus is set to Eraser. If it is, you can choose to change it or just be more careful not to tap the top end of the stylus on the tablet surface unless you want to select the Erasers' Eraser variant.

Hope this helps.

12 December 2005, 10:57 AM
Hi Jin,

It's not to do with the eraser on the brush. I have done all the usual stuff of reinstalling and trashing prefs and downloading latest tablet drivers and Painter patches as well as hidden cache files and any other assorted possibilities. At the moment I am not 100% sure that it is Painter or Wacom causing the prob or some way that they are interacting badly with each other.

I'm really conducting a poll of sorts to see if anyone else has had the same experience as a way of trying to see if it is a problem unique to me and therefore curable.

12 December 2005, 12:10 AM
Wacom behaves in a weird manner if the stylus is not sufficiently far away from the mouse. Have you eliminated this as a cause of your problem?

12 December 2005, 02:05 AM
Good thought, nafa. I forgot about that.

The tablet needs to be several inches away from the monitor and other electronic devices that can cause interference. The usual symptom is a jittery cursor but maybe other things can happen too.

12 December 2005, 09:25 AM
Just to be clear the eraser that the pen becomes, is as if the eraser was chosen as a brush variant, not the eraser at the end of the stylus, which is can be set up differently.

The tablet is well away from the interference zone.

Anyway, if anyone on a Mac has experienced this problem, let me know.

12 December 2005, 12:32 AM

I'm using macos 10.3.9 + an intuos2 and I don't have your problem. It looks like something goes wrong with your tablet.

Does it always switch to the default eraser?
Have you tried with another application wich use the stylus eraser, like photoshop?

12 December 2005, 05:52 AM

Thanks for your reply.

Let me be clear on this. The stylus tip changes as if the eraser was selected from the brush selector bar. It has *nothing* to do with the eraser on the back end of the stylus.

There are no other problems with the wacom. Works perfectly in Photoshop, Illustrator, Zbrush and so on.

At first I thought it was because the back end of the stylus got too close to the tablet. But that is not the case because that is a *different* eraser variant. In any case I have the stylus eraser always disabled for all my programs.

12 December 2005, 02:45 PM
I think what he is talking about is when after you use eraser tip of the stylus and flip it back the brush tip of the stylus it gets stuck on the eraser mode , in the process making you have to manual select the brush from your palette all over again. Its happened on a number of ocassion

12 December 2005, 08:36 PM
Perhaps I'm still not being clear enough...




It is nothing to do with getting stuck.

12 December 2005, 12:06 AM
That's a weird problem. Maybe your Wacom is defective? Have you tried contacting the tech support of Corel and Wacom?

*To everyone else*

He's saying that without having ANYTHING to do with the physical eraser end of his stylus, the brush he's using while drawing/painting just randomly jumps to an eraser brush--which is a different variant than the default one that the physical eraser end of the stylus switches to anyway.

12 December 2005, 07:22 AM
Yes that is right. It may as well turn into a scratchboard tool for the difference it makes. But it doesn't just randomly become any brush, it chooses to be an eraser.

I cannot see how it could be a hardware problem only in Painter. Under normal circumstances I'd think that it can't be to do with Painter or Corel because I'd surely have heard complaints by now.

However I am reminded of the Painter community's attitude to the ridiculous "visibility mask" (in Painter 6) that left destructive edits on your artwork. I first brought this up five years ago and to my surprise not only did no one care but I was abused for daring to suggest that it wasn't meant to work that way. Amazing but true.

Due to the lack of complaints this was not fully rectified until Painter 9, that's 3 full upgrades.

Which is the reason for this thread. I just want some kind of confirmation from someone that they have also experienced this problem with the brush variant changing to the eraser. If no one complains then I can't ask Corel to fix it.

Maybe it is a malfunction but I can't see how. I've eliminated every thing I can. Mind you I can't see how it is software either. But there you go.

12 December 2005, 08:38 AM
That's a weird problem. Maybe your Wacom is defective? Have you tried contacting the tech support of Corel and Wacom?

*To everyone else*

He's saying that without having ANYTHING to do with the physical eraser end of his stylus, the brush he's using while drawing/painting just randomly jumps to an eraser brush--which is a different variant than the default one that the physical eraser end of the stylus switches to anyway.

The default Erasers variant my stylus selects when I flip it upside down is the...

Erasers brush category's Eraser variant.

I guess you mean it selects another Erasers variant?

Don't recall if this was mentioned already, but I wonder if deleting the wacom.dat or tablet.dat file, then rebooting, would help. That's for Windows and I'm not sure what the equivalent would be for Mac but Wacom should be able to provide that info.

Also don't recall if the tablet driver was mentioned but that, too might be the cause.

I agree that contacting Wacom Tech Support is the best thing to do, but not Corel unless Wacom can't help, since this doesn't feel like a Painter problem

12 December 2005, 01:43 AM
Been doing a bit more investigation and I'm coming to the conclusion that there is some kind of a conflict between the stylus end eraser and the normal eraser category that can be chosen like any other brush.

I'm not sure about this so perhaps you could check Jin, in Painter 6 I seem to recall that when using the stylus end eraser that it was still possible to use the eraser tip to select different brush categories. So that you could set your eraser to in fact be any brush. P9 the stylus eraser is always an eraser. Not only that but it is always a default eraser that cant be changed.

Just like the old vis mask artifact disaster was caused by a conflict between the software and the user both wanting to make use of a visibility mask at the same time for different purposes, I think the strange eraser behaviour is caused also by some kind of conflict.

As a test I set the normal eraser to a block eraser but and then change brush cats, restarted and then chose the eraser category and it had reset to the standard eraser. Although when I did it a second time it remained as a block...

I'm a bit busy now but I'm going to have to do some time consuming methodical investigation into this.

12 December 2005, 06:21 AM

Yesterday, my stylus eraser worked and I was even able to reset the sensitivity to soft.

Tonight, it won't work at all, either to erase or to select another variant, in Painter IX and Painter 6.1.

Sorry I can't test it reliably. I don't know if, yesterday, it would have worked to select another brush variant in Painter 6.1.

Happily, I don't use the top end of my stylus for anything.

Later, when I'm not busy, maybe I'll try deleting the tablet.dat file and rebooting to see if that gets the stylus eraser working again, more out of curiosity than need, however.

12 December 2005, 08:50 AM
This is getting even worse.

Now my stylus end eraser is working how it used to. That is I am able to use it to select with so that I can make it into a different brush. Which I have now done and I'll see what happens.


See if this gets your eraser working again. Go into general and change the expression from 'pressure' to 'none' and then back to 'pressure'. That worked for me.

12 December 2005, 10:53 AM
Nope. Nothing about it works.

It might help to know which brush variant you were using when changing from Pressure to None to Pressure, and which of the Expression lists you used in the General palette.

Though I can't imagine how or why that would affect how the stylus eraser is working. I'm wondering now if maybe the stylus might be broken. I've been using mine steadily for two years, all day every day, many hours a day, for everything, not just in graphics programs.

Still, I almost never have used the eraser end of my stylus since I find it a big nuisance to flip the pen upside down when I can just as easily erase using it normally.

I think it's time to call Wacom!

12 December 2005, 05:30 PM
This happens to me quite a bit. I'm usually going so fast flipping the pen around I think the switch doesn't register. I usually have to reflip the pen and tap it to get it to switch back to brush. I should read these responses to see if this is really a problem. I'm just used to it. Isn't this why ctrl+z was invented? :)

CGTalk Moderation
12 December 2005, 05:30 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.