View Full Version : Max UV Mapping Problem On PS2

11 November 2002, 10:02 PM
I'm currently working on a game for the PS2 and I'm getting a line in the seems of my textures when I look at my models in-game. I'm working on some buildings and all the polys are perfectly square. It appears as though a one pixel edge of the texture is wrapping around to the other side. It's very visible when I use a texture that's light on one side and dark on the other. I've made sure that the uv's in Max are precise by actually typing in the uv coordinates in the Unwrap UVW modifier. Anyone experience this before and know a work-around?


11 November 2002, 11:10 PM
u said two of my favorite words...
ps2, and game...

what kind of game is it>? (sorry that this may not be helping ya much but hehe, i really wanna know oO)

11 November 2002, 11:33 PM
It's a major movie license, but of course I can't say more than that. :shame:

11 November 2002, 03:32 AM
Drop some clues ,..... How many people are working with you on the PS2 game ? Do you have really high expectations for this game ? what gerne will it be [ shootin ,sneakin,rpg ...]

11 November 2002, 03:52 AM
Guys, not to be rude. But he is posting for advice not to be bombarded by questions. There are other places for that, this is not it. Its cool to be curious, but if he said he can't talk about. He can't.
As far as the problems go I can only offer minimal suggestions that you've probly already tried, but here is my two cents. If its simply planer the best solution may be to just remap the UVs, time allowing of course. You could also try just applying a simple checkerboard texture and seeing if it happens with that, it may help narrow down the problem areas. Also you might want to try rearrangeing the UV map some, there may be sections that are overlapping but may not seem like it. One last issue, that would suck, it may be the engine itself and the way its reading the UVs on your model.
Again this is just based off what I think might help you find a solution. Sorry I can't be more precise. Good luck,

Marc Andreoli
11 November 2002, 09:30 AM
try setting the 'tiling' (material editor-map) to just below 1 (for example 0.99). This stretches your texture out a tiny bit, hopefully just enough to get rid of that one pixel bleed...

11 November 2002, 06:43 PM
Like Marc said... try to make the UVs a bit smaller. I remember we had the same problem on the PSX Pixel bleeding caused by the texture page. We had 32x32 Pixel for PC, but only 16x16 for PSX which is a problem if your UVs are too perfect (0-1). No bleeding on PC but on the PSX you could nearlly see the Wireframe :).
The biggest problem after resizing our UV was that all the seamless textures where no longer perfect seamless... no prob on the PSX with that because its way to blurry to see anything, but on PC it was disgusting. Well our coders found a solution for that...not perfect but okay, but i can still see it, while a "normal" user wont see it.

I talk too much.

Make UVs smaller... leave one or two pixels around your image.


11 November 2002, 05:22 PM
Thanks for advice. I kind of figured it was an ps2 engine issue. I'll try talking with one of our programmers and see if they can do anything. There's only so much I can do on my end. Messing with the uv's works fine if every poly is mapped individually, but we're using tiled strips and the polys in the middle of the strip get even more messed up when I make the uv strip smaller or change the tiling to a smaller number.

And about the game, I'd love to talk about it more but of course we're sworn to secrecy. Let's just say it's a very short production cycle and we're really under the gun.

12 December 2002, 09:24 AM
What you are seeing are the effects of Bilinear filtering. It happens on every system. Make all of your textures with a two pixel border. This is pretty much SOP.

CGTalk Moderation
01 January 2006, 05:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.