View Full Version : batch render ignores -rd flag

11 November 2005, 11:17 AM
I've been rendering some scenes from a .bat file ias is my habit but all my output has been going to the wrong place - ignoring the -rd flag and going instead to the directory specified in the project

The script I'm using is like this :

render -r mr -rt 4 -s 486 -e 539 -b 1 -cam AniCamA -rd F:/path -im filename F:\path\scene.mb

I think I'm right that the rd path should use forward slash and the scene path backslashes, but I tried both with backslashes too and no difference.

Is this a new maya 7 'feature'? Has the syntax changed? - I can't see any changes if I do render -help -r mr.

any help appreciated

11 November 2005, 12:19 PM
The -rd flag has been broken for Mental Ray in Maya 7. Instead use the full path in -im flag, like: -im F:/path/filename.

Hope this helps,

11 November 2005, 12:28 PM
This is the bug fix

11 November 2005, 01:09 PM
brilliant, thanks very much. Not tried the -im flag with full path but the fix works.

CGTalk Moderation
11 November 2005, 01:09 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.