View Full Version : blendshapes screwed

10 October 2005, 11:47 AM
Hi, ...
i have a big problem with my blendshapes...

I have a char with about 10 blendshapes on it for the facial animation. When i move the char they just screw up (eyes not closing propperly, mouth not closing, etc.). I deleted the targets for the final char as i went to animation. All origins set to "local". This is really driving me crazy right now. Is there any way to save my done work on the scene ?!

everything seems fine, when im in bindpose. So it has to be something with the rotation/translation/scaling of the char. omg
Do i have the blandshapes match the orientation of the char !? A simple "parent" would maybe help...

EDIT: ^^ nahh doesn't work...:sad: eaven, when i rotate the blendshape with my char

Bindpose -> everything works fine
when i rotate the char (he lies on a bed), they are screwed.

please help !

EDIT 2 : seems i solved the problem by myself, ... it works, when i do the following when creating blendshapes:

- go to bindpose
- duplicate the char
- move verts around as wanted
- rig the modified blendshape target to the skelleton
- copy weights from original char
- create blendshape (default options)

problem : i cant delete the blendshape target ... otherwise its screwed up again !

is there any other sollution, because the scene gets heavier and and havier ?!?!?!

EDIT 3 :

yeeehaw, ... solved the problem ... was a simple deformation order problem. Everything is back under control now ! =)

thxXx anyways for the fast replys :D

CGTalk Moderation
10 October 2005, 11:47 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.