LC #42 Pipers Alley

View Full Version : CBdeleteConnection - Cannot find procedure

09-08-2005, 11:49 AM
I'm trying to learn about fluids by looking at the presets and I ran into a problem.
I'm looking at and applied gunApply.mel as the notes say, but when I run the script [also in the notes] I get the following error :

// Error: line 5: Cannot find procedure "CBdeleteConnection". //

line 5 reads :

CBdeleteConnection ($fluishape[0] + ".currentTime");

I've searched around for the command but it seems there is indeed none such. I deleted the connection manually in the hypergraph and the rest of the script seems to work fine. Can anyone tell me the correct command to use?


09-08-2005, 01:30 PM
CBdeleteConnection is a global proc that is contained in generateChannelMenu.mel in your maya/scripts/startup folder of your maya installation.

source generateChannelMenu.mel;

will put this proc into memory and get rid of your error.

09-08-2005, 01:37 PM
ok, I'll try that. Thanks for the help.

09-09-2005, 07:16 PM
you should also read this thread about it:

right-clicking and breaking connection from the channel box sources the procedure. Then you can use it.


09-09-2005, 07:33 PM
Thanks for that - my mel is pretty poor but it's good to at least understand a bit of what's going on and why it doesn't work when it doesn't

CGTalk Moderation
09-09-2005, 07:33 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.