View Full Version : 30 min now...

08 August 2005, 12:39 PM
It has been 35minutes now and xsi is still trying to merge 8 polymeshes
scene size is about 55 megs
polymeshes to be merged are about 25megs
processor is about 2 gigs 1gig ram and is working 100%since
i know some other ppl had similar problems
is xsi stuck in a loop?

08 August 2005, 12:51 PM
Make sure you freeze the meshes before you merge them, that can speed up quite a lot...

To check if xsi hangs, open the task manager and check the memory usage for the xsi.exe process, if the amount of memory used changes every now and then its still going, if not, kill xsi and try again..

08 August 2005, 02:13 PM
yes it is as you say
ram consumption is at same level. 707megs this scene is a beast!
I quess it was calculating all the new polygons
do you know a way of merging objects without having it
to calculate all the new polygons
0 tolerance?


08 August 2005, 02:59 PM
Did you try freezing the objects first?

Also, you say each object is 25mb, how many polygons are we talking about here? I've managed to merge really heavy scenes (1.8mil polys made out of around 2000 objects) into one single polygon mesh without any problems. Sounds like each object has a lot of construction history or something, make sure you clean the scene properly and make sure no object has more polygons than it needs to, I often see stupidly high polycounts for objects that could have been modeled with 1/10 of the polygons...

The other thing you can try is to first merge 2 objects, freeze those and then merge another object in there, that way you should be able to get some feedback more quickly.

08 August 2005, 03:11 PM
freezing doesnt do it.
My scene has about 900 trees which are loaded as one xref model, thats
why the ram consumption is high i quess.
What i am trying to megre is the grass, it is 200,000 polys.
Ok i could do it with hair but i dont have time to do so.

there is not crucial to merge them but i just whould like todo so to keep
my scene "healthy" :)

well i tried merging one by one and i found out that one of these objects must be corupted
very strange.

thaks for the help wurp

08 August 2005, 09:08 PM
Just as a side note. xfrog real 3D trees can be real nightmare, those weight A LOT! Wherever possible I try to instance them.

A while ago I tryed to do some grass via instancing to the mesh and merge later separate parts together...that was no go. XSI just died while I tried to work with them, had to use hair :s

Anyway zukezuko, let us know how it goes and if corrupted object was causing it.

08 August 2005, 01:05 AM
Well, i dont have that much weed, only some areas around the trees have weed
thank god...

This is a screenshot of those weeds

most of those merge fine, but a couple are corrupt.
The scene works fine as is, no problems there, just when i merge those..
I freezed them, freezed modeling and freezed trasformations but still crash.
Cant find o solution to it, but it is not importand for my project so i dont care very much.. :)

08 August 2005, 01:53 PM
you may need to remove the ones that are corrupt.

08 August 2005, 08:08 PM
no time to bother,
So what do you guys think of this :

CGTalk Moderation
08 August 2005, 08:08 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.