View Full Version : Influence object not visible in component editor

07 July 2005, 03:40 AM
This is my first time to use an influence object parented to a joint and like many things in Maya, it's looked simple at first...

I've gone through the steps: start in bind pose, create poly snapped to skin surface, centre pivot on poly, delete history on poly, parent to joint, freeze transform on poly, select skin and shift poly, goto add infl.ob, lock weights on, use components on, disabled weight normalization.

Selected vertices on the skin to be influenced, went to the component editor's tab for smoothSkins and ..... nothing! Nothing after several attempts at the same thing. All I can see are the original joints in the skeleton and the vertices which I've selected. I had the impression that I should also be able to now see the influence object here so that I can transfer the weights to it.

Does some marvel out there know what's happening?

07 July 2005, 07:17 AM
did you close and reopen the component editor after adding the influence?
you gotta remember just how crap the component editor is...

you can force it to update with mel..
compEdMenuCmd CEMIAutoUpdate componentEditorPanel1WindowComponEditor;


07 July 2005, 11:25 PM
Yes, I've tried opening the component editor several times and there was no change; it still lists the joints only under the Smooth Skins tab.

I entered the script into the Command Line with no changes, but thanks for that - it may still come in handy.

It's probably something that I've missed, but I'm happy to bang away at the component editor if there are other fixes which I can try.

07 July 2005, 02:11 AM
Well, one of the influence objects works now. I have no idea why things changed. I just ran that script several times, open and shut the component editor, selected things and made another couple influence objects and waddayouknow? - The first of my influence objects appears in the component editor, but not the other two.

I'm bungling about a bit, feeling a bit of a wally as I'm kind of blind to why things have changed. I hope it was that script because I'm b*ggered if I know what happened otherwise.

I hope I don't have to bang away too much at the keyboard before I get the rest to work.

Cheers matey!

07 July 2005, 05:38 AM
this might seem basic.. an even insulting.. but I have no Idea of the level your at so...

you dont have "hide zero columns" on do you?

BTW, I've found it usefull to map that script to my undo hotkey (z) so that when I undo something, maya updates the CP editor as well (cos it wont if you dont make it).

so it looks like this...

compEdMenuCmd CEMIAutoUpdate componentEditorPanel1WindowComponEditor;


07 July 2005, 06:28 AM
If you mean the "Show All Columns", I had that checked at the time and all the usual columns were there. I think that script you suggested works now, maybe not first time, but I haven't changed anything other than using the new script and opening and shutting the component editor - after a while it gives me what I want.

I'm an absolute beginner and I don't mind if you suggest that it may be basic things as it's often the case.

I'm finding that I have a few problems with influence objects as well as the Clusters, which I've only started to tackle this week. I could go into it, but I don't expect you to hold my hand all the way; I tend to use the forum when my hair's just about to drop out and so I appreciate you taking the time to assist.

I had a look at the hot key editor and I wasn't able to change the default script for undo to the one you suggest, so I disabled the default Undo and set up a new one. It work's now, thanks :)

CGTalk Moderation
07 July 2005, 06:28 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.