View Full Version : Out of Memory ???

07 July 2005, 05:41 AM
I went to add an eco to a scene I was messing around with, and this is the
message I get every time, yet, it appears that I still have loads of memory?
Is there something I need to know about to make this NOT happen?
I know I still don't know what I'm doing yet, but am curious if I did something
bad that caused it to give me such an error message, especially since you
can see that I'm barely using up any memory in the task Manager.

Anyway, Still having fun :)
Loads of fun, actually, and mostly I've just been going through all the tools and settings
and where things are and what they do, and yet I'm still having fun with it all.
But, if I'm going to need a better system, then I'm going to build me one with 4gigs
of RAM, if that's what it takes, as I'm currently running with 2gigs right now.

Though I would of thought that that would be plentey of RAM, no?

And the one good thing is, that even though I get that message and it basically,
freezes up on me and I have to do an Alt+Cntrl+Del to force quit it, it at least seems
to be great at recovering the last scene as it wa last left without it loosing much.

Anyway, till I figure this part out, I'm on to more basic scenes for now. :)

07 July 2005, 06:11 AM
I don't think it is a RAM problem. I run Infinite (Mac version) on 1 GB Ram without too many of these messages. With none so far i think even. It becomes sometimes a little slow, but thats how it is and gives you time for other things.

By accident you covered the polygon count on your scene but what i could see the scene does not look too complex.

What you could try out is to switch off OpenGL as a test. Maybe it is more this than anything else.

I have this message sometimes on my VERY old Windows box that i use for rendering sometimes. And simply ignore it - the system does not freeze at all, becomes only slower a little. Not a big deal because scene setting os over there anyway and only rendering is demanded.

So when your system freezes i guess there is an incompatiblity with anything else that is running in parallel i would say. Or again, a graphic card driver issue. Vue is very sensitive to those things.

07 July 2005, 06:32 AM
Hmmm,,, well, I didn't think it was me being out of memory, but you never know?
And no, it wasn't that big of a scene or anything.
Only 131,000 polies, so that isn't didly squat.
As for the drivers issue, I did the Test Display Card thingy, and it came back saying I was fine.
But, I'll check for any latest drivers, just to be on the safe side.

I may have just screwed up the scene somehow or something, as like I say,
I'm still going through the motions of learning it :)

I'll mess with it some more in a while, as right now I have to finish installing a couple
of other apps that I still haven't installed yet, since my reformatting.

Anyway, :)

07 July 2005, 06:48 AM
Well, ya know, now that I've rebooted and all that and looked at things more closely, I realized that it maybe wasn't froze up, but just taking it's time to do something.
Cuz now, it made 53 billion+ polies for the scene and is rendering away right now.
Using up 100% of the CPU though, which I guess is what it should be doing, right?
Or is it supposed to use up the whole 100% of power from the CPU?
PF Usage is only running at 537mband 1.3gigs of available RAM.

So, there ya go and who knows what I did?
I do remember reading about this very same message, long before I ever
bought the program, some place but can't recall what it was about?

Anyway, only took 4.2 minutes to render out the whole mountain side
there from up above a bit high looking down at the mountain.
That was a 640x480 render also :)

So, that was pretty good, considering I've never even
seen a scene with over 53 billion polies in it!

Anyway, as much fun as I'm having, I unfortunately need
to stop for a while and deal with these other programs.
Boring LOL :)
P.S. Now I'm rendering away and having fun!
No clue what the deal was with the memory bit?
At least I'm rendering away now though :)
Still though, I already have been researching getting me a new system.
One like a dual core and of course, loads of RAM and a good vid card.

07 July 2005, 11:16 PM
When I am rendering, the task manager frequently shows CPU maxed. But then, I'll open my browser or Outlook or whatever, and I don't crash. Vue continues to render and I do other stuff. I think Vue takes what it can get at the time. I'm rendering now, actually. As far as memory problems, have you installed the updates? Even though they are "beta", the updates have continued to help the memory problems that occurred with the first release of Vue. Be sure to check the e-on site occasionally, as the automatic update feature of Vue doesn't work with "beta" releases

07 July 2005, 11:43 PM
Yeah, at the time of those error messages, I had several programs open, like I usually do.
I hate just sitting here waiting for renderings, so I have other things going on to keep
me busy, like the internet or some other thing and yes, the very first thing I did was
to install the update, though I'm not sure how often to check back for updates,
as I don't know what the normal timing for releases are for e-on?
But I've only had it for three days now and I installed the latest
version they had three days ago, which it said was a beta.

Sadly, I had to do truck maintinance and other chores today,
so I never got a chance yet to play with Vue today LOL
But, I've been reading the manual while I waited, so thats always a good thing ;) :)

07 July 2005, 04:28 PM
you´re truly obsessed by vue :) (which is a good thing btw)

07 July 2005, 08:56 PM
Yes, I guess I "am" obsessed by Vue :)
The computer hasn't been off since last night, as I was rendering half the evening away
trying out things and went to bed and woke up at around 3am and couldn't get back to
sleep, so I checked on my render and ended up playing till long after the sun came up.

I had managed to get my very first DEM loaded in, all on my lonesome too,
and I did that before I even got a reply from whoever it was who posted up
those great links for getting DEMs and such, which I'll be checking into today.
The first thing I realized about terrains of ANY type, is how the flip are you
supposed to know just how big they are and in the case of things like DEMs,
how do you kow which is North and South and like that?
And the DEM file that I was able to convert into a DEM, ended up with an edge going
around it, like a wall or something and could not find a way, so far, to erase that edge?
I'm going to go and check out those links right now and see what I see.
If I have to, I'll just pay for some decent DEMs, as I need them to be of
fairly good quality for what I have in mind.

BTW, the program I ended up using last night, though a command promt style app,
which I'm lame at working with, it had a basic tutorial and I did it and it worked!
Pretty cool, actually, considering I didn't have a clue what I was doing until it was over LOL

And now I just got my Wacom Tablet delivered (yay!) and have to hook that puppy up.
So I'm going to be in heaven for quite some time playing with Vue and learning the tablet.
Should make editing things into terrains, like dirt roads and such, a lot easier, I hope :)
Too bad I ran out of USB ports, which BTW I could never imagine ever doing, but I have.
Add a printer and a dongle for LW and a digital camera and something else and the next
thing ya know, you're out of USB ports!
Yikes! LOL

Anyway, yes, I am already addicted to Vue and can't barely get
anything else done around here, cuz it just keeps calling me LOL :) :)
P.S. And yes, I have still been gtting those, "Running out of resources and or memory"
messages and then most of the time I have to do the force quit bit.
Still not sure why this keeps happening, unless it's just because I'm trying
to add tooo many items per scene or something? As this does happen when I'm
working with the Eco-System and it happens when I go to Populate the terrain.


07 July 2005, 06:57 AM
I got the same out of memory error a few times when trying to render a scene with 237 million polys. Other times Vue would just 'disappear'... *poof*, gone... My system also showed that RAM was okay around the time that Vue informed me it was out of memory. Weird. I'm using Windows XP on a 3.1Ghz HT, 1GB RAM, and an ATI Radeon 9700 video card.

07 July 2005, 07:17 AM
jasonarcher, well, thats not that much different then my own system.

This is what I have:

LW 8.3
XP Pro sp2 5.1 (build 2600)
P4 3ghz HT 800 FSB
2gigs DDR RAM
ATI Radeon 9600XT 256megs
2- 40gig IDE HDs
1- 160gig SATA HD
DVD-RW 12x
CD-ROM 52x

What's funny is, is exactly what you mention, which is that you still had loads
of RAM left when these errors happen, which is the exact same thing with me!
But not only that, I had these errors a few times, when I was in the millions of
polies just like the amount or even less, like 83 million, and yet, I've already
rendered lots of other scenes that have OVER 54 BILLION! polies in them,
with no troubles at all!
So, it can't have anything to do with how many polies are in the scene,
which leads me to think it may be a glitch or even some sort of a bug or
something like, if you do a few certain steps first, then it gives you this problem?
I don't know, but I "AM" keeping my eye out on my moves to see if I can catch
whats happening and maybe figure this out, cuz something's up, for sure.

Glad it's not just me though, even though it's not a good thing.
But at least I know others are having the same issues with this as I am. :)

07 July 2005, 11:47 AM
if you do find anything that seems to be reproducable, file a bug report to (

one thing you could try and do is lower the number of undo operations, seems to help some people.

07 July 2005, 04:09 PM
BTW, thanx, I will file a report if I can narrow it down and get it to crash on command :)

But yes, I originally had my Undos set all the way up, not thinking that was an issue,
untill I read something about it somewhere, i can't even remember where? It may have
been in a suggestion message that poped up suggesting reasons for these problems,
which BTW, I thought was pretty cool that the program was trying to help me solve the issue.
But, I lowered it all the way down and still got those messages.
But, I'll check again, as I may have it set to 3 Undos instead of just the one, but boy!,
that's pushing it and makes the Undo really useless if I can't have more then just one Undo.

But, like I say, I'll check that and also still keep my eye out on this and I'll load up the
same scene that I was getting the crashes with and see if I can force it to do this again. :)

07 July 2005, 05:12 PM
Hmm... It doesn't seem to crash when I enter compatibility mode. It may be the OpenGL, as mentioned earlier. Perhaps a better video card would help? The amount of system memory doesn't seem to be the issue (undos and whatnot) because there is still a pretty large amount of memory left free when Vue says "out of memory".

07 July 2005, 05:19 PM
vue can be touchy about opengl and certain video cards/drivers, so try the latest and greatest drivers first and foremost, if it still crashes try disabling opengl (it is afterall a known issue with some cards/drivers) if that helps then you´re left either working with opengl disabled or getting a new gpu.

07 July 2005, 05:24 PM
The problem I have with the type of card is, that mine's one of the ones
they have listed as being a suggested card to use in their system requirements,
so that doesn't seem right to me?
And it (Vue) says, when I do that test thingy, that my card is fine.
Though I'll check for new drivers later today when I get the chance.

As for the OpenGL, if you aren't using that, then "what" are you using?
I'm sort of lost in this whole area? :)

CGTalk Moderation
07 July 2005, 05:24 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.