View Full Version : Can't use for than 1GB momory?

03 March 2005, 07:11 AM
I have had 2 GB RAM installed for almost a year now, and I just found out I've nevered used the second GB at all! I always just assumed I never needed the 2nd GB, but today, when I right clicked on My Computer->System Information->Memory, it tells me "Error finding first module." I booted up Photoshop and made one giant file with tons of layers, and YUP, after I fill up the first GB, things just crawled (I have Cacheman installed, and it indicated that I can only go up to 999 MB as well).

So, I pulled the memory sticks out (4 sticks), and made sure there's no excessive dust, and then pushed them back in--in a different order than before, to see if that changes anything. I ended up getting the same error message still. I ran Docmem and it froze after 2 seconds. I ran Memtest and it tells me that my version of Windows *WinXP Pro, SP2) only allows a GB to be used by any software at once, and I should run two Memtests at the same time, testing 828 MB of RAM each (which I'm doing as I'm typing this). Both Memtests are running, so that means all 2GB of my memories should be working. But how the hell do I make WinXP allow softwares to use more than 1GB? And why am I getting the "Error finding first module" message when I check the memory of my system information?

03 March 2005, 08:19 AM
Ummm, perhaps completly unrelated, but are you running an Athlon64?

03 March 2005, 08:32 AM
Many motherboards will work fine with normal ram up to 3 slots, but will require ECC/Registered RAM for 4 slots or more.

Consult your motherboard manual for more info.

03 March 2005, 09:10 AM
Weird. Windows XP works with 4GB (2 for apps and 2 for the system).

I'm not a hardware guru, but:

when you upgraded the memory, did you get exactly the same modules? Modules from different manufacturers, even if nominally the same sped and type, sometimes simply won't work together.

have you tried borrowing two 1-GB modules and installing them? Of course, if you can.

what does the documentation of your motherboard say about memory? Any jumpers to be set?

03 March 2005, 11:20 AM
I don't know what memtest is talking about, XP has a standard limit of 2 gigs per app, not 1. As already mentioned, some (specifically a64) motherboards go a bit funny when you fill up the 4th slot. For example mine will work fine with 3, but once the 4th slot is used, the memory speed will drop down from 400mhz to 333mhz. Trying to run it at the full speed results in errors.

03 March 2005, 05:29 PM
Generally, the problem with ram is when you have too many slots filled up, there tends to be alot of interferance and noise on the lines. Most parallel devices suffer from this (partly why so many things seem to have gone serial recently, PCIe, RDRAM, SATA, etc.). So, when you plug in all these high speed ram modules into all 4 slots on the motherboard, the system will default to a lower speed (like the post before mine) or wont work at all. A solution in this case would be to use Registered DIMMS (which have error checking), or use larger sized sticks and less slots on the motherboard. However, I'm guessing you'd like to keep the ram you have ;) So why dont you try to lower the speed and losen the timings at which the RAM is operating at. This may help clear up the problem.

Of cource the Registered RAM is only an option if your motherboard supports it..

03 March 2005, 04:08 AM
I am in the same boat, but if I remember corectly (dont have access to PS or the manual at the moment) in the preferences for photoshop you can set how much memory it uses, and the default is 50%. I'm also no PS guru, so this my be something compleatly unrelated.

03 March 2005, 05:15 AM
I'm getting conflicting information now when I try tests. Memtest+ (an enhanced version of Memtest) freezes randomly when I do boot tests (sometimes soon, sometimes after a long time, but the test never finishes at 100%). I tried another Photoshop test, and this time I don't rely on Cacheman's taskbar disply, but open up the app completely to look at the information tab. This time, it shows I'm using all of the available memory (about 1,600 MB). So, for some stupid reason. Casheman's taskbar display can only go up to 999 (and got me thinking I could only use 99MB). I still can't explain the "Error finding first module" thing though, or why Docmem tests always freeze at 2%, or why Memtest tells me only 1GB could be used per app. :shrug:

CGTalk Moderation
03 March 2005, 05:15 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.