View Full Version : Discovery Edition problems, anyone?

09 September 2002, 11:02 PM
Hey there! I'm not actually a Lightwave user--I just recently followed this link ( (from this post (, and ordered the demo.

Well, it arrived today, in a plain white envelope. Hand-written addresses, flimsy half-height jewel case (definitely not meant for mailings), and a CD-R with one HELL of an ugly black and white sticker on it, and was apparently shipped from some company called "Clarix"; I assume that's a local (New York) distributor, or something similar. Quite frankly, I could've shipped a more professional looking CD myself. Very disappointing.

HOWEVER! I thought, "I'm not one to give up easily, and shan't let that ruin the program itself. I've never been a fan of the interface, but with a little practice, I'm sure I'll feel right at home. Now, lemme just install this..."

It didn't install properly the first time. It created start menu icons for LightWave 7.5 DE, and the Modeler, along with a link to register (but only useful for full, commercial copies, not the DE), but didn't install the actual software.

Now, it seems, all the necessary programs are on my hard drive, in the correct places, and I can run LW, Modeler, and the Hub, manually, just fine.

But the "Modeler" button doesn't work. No matter how hard I try, I can't get this damned demo to work right!

Any ideas?

yon dabuda
09 September 2002, 11:09 PM
"in a plain white envelope. Hand-written addresses, flimsy half-height jewel case (definitely not meant for mailings), and a CD-R with one HELL of an ugly black and white sticker on it"

well i think its cool that someone personally put that together for you :) and sounds like you didnt have to wait very long.

09 September 2002, 11:36 PM
I'll look into this...sounds like a local dealer sent this one out...Let me know if you have any questions about the CD that I can help you on.

09 September 2002, 12:01 AM
You have to start both modeler and layout manually the first time. After that, the hub should recognize both their positions and the switch should work.

09 September 2002, 12:03 AM
No, no, I appreciate the fact they'd do this kinda stuff for their potential consumers, it just seemed.....suspicious, I guess. I've ordered free (yes, I mean free; no shipping charges to speak of) demo cd's before, and usually get a fancypants commercially stamped/printed disc. Don't wanna risk getting caught up in any potential shady third-party dealings, you see.

But for the life of me, I can't get the Hub to work; the "Launch" option of the taskbar icon says "Empty", and on top of that, the Hub doesn't startup along with Lightwave--isn't it supposed to?

I've uninstalled and reinstalled the program several times now, but can't get things running smoothly. I can manage to open the Modeler, and create a cube, but can't get it into the main Layout program without the Hub...can I? I hope I'm just doing something wrong here; If I am, please, lemme know.

And, on a semi-related note, is there a reason I can't find the link to that Discovery Edition CD order page from the main Newtek site? Only after reading Leigh's post (linked above) did I realize it was even released. I also thought there was going to be a downloadable version at some point...

Anyway, I hate to be a pain; just want to get this working so I can screw around. :p

OH! Wait! One more important thing: why aren't my renderings watermarked? Sure, since the Hub isn't working, I can't create any objects, but I can still render the empty scene--shouldn't I still see some sort of "Discovery Edition" text?

09 September 2002, 12:23 AM
The renderings have a checkerboard watermark pattern....

I found out that we have loacal Dealers sending out Burns of the DE to help fulfill orders....You would probably still be waiting if we didn't do that....Conatact Tech support to see what the issue might be with th ehub...I'm not sure what that is about...

Try clicking the Hub.exe file to see if you can run the hub that way....

09 September 2002, 12:33 AM
Oh, please, don't misunderstand--I'm happy you're doing what you can to fulfill the orders, and I'm glad I got my copy so fast. But I wanted to make sure--ABSOLUTELY sure--this is what I was supposed to receive.

Thanks for checking that out! :buttrock:

09 September 2002, 12:42 AM
I understand...I'm just looking out for you is all....:thumbsup:

09 September 2002, 12:50 AM
Correct me if I'm wrong.. But the HUB is network dependant, right? :hmm: In that case, could it be a firewall playing some tricks on Lightwave? :shrug:

09 September 2002, 12:50 AM
Hey don't feel like the Lone Ranger, I ordered one too. My disk also came in a plain white cardboard sleeve. However, the one I received had no jewel case at all. It was sent from a company called "Tape Duplication Supply and Studio" out of Kent WA and a telephone number was listed.

As for the disk itself, the label is matte white with "Special Discount Price on Lightwave 7.5 available through: Authorized Newtek Reseller Tape Duplication Supply."

So it appears to be even more of a marketing ploy than I originally expected. A teaser of sorts.

I had no problems with the install, everything went smooth as silk. Upon testing the software, I found half of the modeling features inoperable due to the 400 point limit on a object. Not to mention I could not figure out how to "undo" withing the modeler.

That's my 2 cents. :)

Lizard Head
09 September 2002, 12:59 AM
Hey at least you guys got yours!!! I ordered mine like five years ago.. still, I wait everyday at my mailbox, everyday I curse the mail lady for bringing me just bills.

09 September 2002, 01:06 AM
Try running both modeler and layout from wherever you installed it. c:\lightwave\programs or something. After you've run them both that way the hub should be able to switch. At least that was what I had to do when I had your problem some time ago.

09 September 2002, 01:43 AM
Hmm....this is intriguing. I actually DO have a little home network set up; two computers, sharing a cable connection via a Linksys Cable/DSL router.

But I've tried running the programs by double clicking their icons in their native folder (C:\LightwaveDE\Programs, in my case), to no avail. Regardless of the order in which I run them, I still get no results.

I guess I'll contact tech support, see if they can help...

09 September 2002, 04:03 AM
have you tried a fresh install....might help..

Chuck Baker
09 September 2002, 03:19 PM
That's really curious, Redcon. The 400 point limit only applies when you try to save a model. There is no point limit on the objects that you can model using the demo version, you simply cannot save the ones that exceed 400 points.

The Undo button in Modeler is on the bottom menu bar, right along with cut, paste, etc. The hotkey for undo is "u".

You may want to check with Tech support to see why you would have the difficulties you describe, as they are not standard performance for the demo edition.

CGTalk Moderation
01 January 2006, 05:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.