View Full Version : confusing anti-aliasing bad magic!!

02 February 2005, 01:00 PM
i have a macG4 powerbook with 1GB RAM and ATI graphic card running on panther... i have maya 6 complete and i set the antialiasing to production quality and at 640 by 480 resolution

i rendered an image:
i captured the image using "command option 4" to show u exactly how it looks in the renderview and...i saved it from the renderview using "file> save as".

2 DIFFERENT RESULTS! so now im really confused:

1. i have antialiasing problems... initial and more in need of solving
2. i get 2 results (both not acceptable) for the same render if i save in different methods... explanation please

02 February 2005, 02:00 PM
The first one is 639px witdh.
That means you were not viewing it at 1|1 zoom

You may also take the last image in your project/images directory to ensure it won't be re-written.

02 February 2005, 02:11 PM
its 639 not 640 cos on a mac u draw a box around the part u want to capture and i might have missed by one pixel... but i made sure it is 1:1 ratio

02 February 2005, 02:40 PM
the renderview window occasionally displays glitches that aren't actually there... so just save the image and everything will be fine

02 February 2005, 03:41 PM
thats what i did... i saved it and took a look at it with photoshop...same problem but not as bad as in the renderview.... but its definetly still there as u can see from the pics i attached...

02 February 2005, 09:32 PM
I don't see aliasing problems in the second image, I see jpeg noise in the texture but no aliasing on the edges? If you are talking about the jpeg noise, just save your image in another (non-lossy) format, then convert to higher quality jpeg using an external program/utility.

02 February 2005, 02:01 AM
Hi ooz!

in C:\Documents and Settings\USER\My Documents\maya\X.x

open the Maya.env file in notepad and enter this:




Might work....

- Somhairle

02 February 2005, 06:04 AM
hit th 1:1 button and make sure your render is big enough to fit the full image in it. Then grab the edge of the window and scale it in VERY slightly. Like the smallest amout you can move it. The image will stay the exact same size and will still say 100%, but this could be the problem. It sounds kinda strange, but this is many times the problem. I have it on my computer every once in a while and used to have it at work (on a mac 23" cinema display.) hope that works.

02 February 2005, 07:52 AM
Somhairle, i will try that code see what happens, Sphere♥ i see ur point...

but the renderview shows the problem even before i save it as jpeg, or anything else... so i dont think its a problem that is linked to the jpg format...

could it be a glitch in the render engine that has a patch or something? but it also occurs in mental ray renders...

02 February 2005, 07:44 AM
hey ooz,

I started getting the same problem when I loaded/unloaded/re-loaded the Mental Ray Plug-in. I have most plug-ins unloaded (saving system resources) as I mostly animate.

I had the same sharp "jags" you were getting in the normal maya renderer. :D dunno why!! strange, they weren't there before. they were gone on a re-start of maya!

- Somhairle

02 February 2005, 08:14 AM
itsallgoode9 i did what u said and it worked... the 1:1 button does what is required of it but when i make the zoom 1:1.003 by doing what u said everything worked...

so i guess i have to do this for every render i do... oh well.

thanks guys

02 February 2005, 07:47 PM
yeah it's a strange glitch.....there's acutally another thread from a guy who is having the same problem you are, so you might keep watch on his to see if any info about that pops up.

CGTalk Moderation
02 February 2006, 08:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.