View Full Version : Set Driven Key not updating

02 February 2005, 03:46 PM
Hey 3D geniouses!
Check this out - may be you've come accross something like that:
I have a character with a pretty simple rig. I want to make some animation by creating a control object, adding attributes to it and then use the set driven key to put different animations. For example, I make an attribute "Jump" with ranges 0-10. At 0 the character is at default position. 5 - in the air and 10 - back on the ground. This is pretty simple to do.
I've made already several attributes with some complex movements. And now that I've added another attribute, the driven key won't update the new values.
I made a simple test:
First key - initial position - everything is at 0. Second key - moved it 2 units on the X, made a key - everything's fine. But when I make the third key by moving it 4 units on the X and when I press the key button, the value it inputs the the animation curve is something completely different when it sould be 4! :eek: I can go and fix it manually, but for some more complex movements this approach is crazy! Any ideas?

02 February 2005, 04:07 PM
Maybe you should look into the trax editor? That's designed for storing and blending animation.

What attributes on the character are you driving with the SDKs? Because if you directly drive your character controls that way, I imagine you'd lose the ability to manually keyframe the character. You'd need to create a node above each of your individual character controls and drive those with the SDKs instead.

02 February 2005, 12:17 PM
I'm animation the translates and rotates of the caracter. And you're absolutely right about losing the ability to manually keyrame the character. But that's not the issue. The problem is with the generating of the SDKs. It's just behaving very weird. I think it's a bug because if I erase all the previously made SDKs and make the one I'm having problems with, it works just fine. The only way I could figure out to sort of fix this is very painful, but at least it's possible. It's to make different scenes with different attributes with SDKs and then to manually hook up in Hypergraph the animation curves and attributes into one character. :D

02 February 2005, 12:43 AM
If you pull up the graph editor for your DSK's do you see whats expected but the "action" isnt moving or is are the curves in the graph editor not like they should be?

02 February 2005, 10:26 AM
The graph editor is fine. I can alter the movement by changing the graphs. But this would be quite hard, because for each attribute I have quite a lot of graphs and I have to start guessing which is for what. But the problems comes before that. This is what happens more or less:
Imagine that you have a sphere and add an attribute on it and you hook it up with SDK to the Translate Y (for example). You set a key in the zero position and then set a key at transY = 10 and the attribute is let's say 5. Now when I open the graph editor, I see that the key isn't set for transY=10, but something else. And now imagine that this happens with all of the tranlates and rotates of my character's controls - very unpleasant. I'm pretty convinced that it's a bug.

02 February 2005, 02:51 PM
That sounds pretty bizarre. Sorry if this is too basic, but are you certain you're doing things in the right order when creating the SDKs? In other words:

1. setting the initial value on the driver first
2. setting the corresponding value on the driven attribute(s)
3. setting the key
4. setting the next value on the driver
5. setting the next value on the driven attribute(s)
6. setting the next key

etc.? It may sound stupid, but when a lot of attributes are being driven by multiple drivers it becomes easy to lose track. This happens to me all the time and I think something's buggy, but when I start over and go through methodically it "magically" works.

Have you tried that sphere example you described and gotten the same behavior? If not, it's possible it's not a bug and more due to the complexities of your setup.

02 February 2005, 10:40 PM
Sorry if this is too basic, but are you certain you're doing things in the right order when creating the SDKs?

I'm working as an instructor in Maya. Don't take this the wrong way. I just to let you know that I'm pretty familliar with the process. The example with the sphere was just to make it easier to understand. I know that something with SDK is wrong, because I sort of debugged it - I followed all the connections between the nodes and thus I found out about the problem. I'll try to post the scene file, but it kind of a problem, because this is actually the work of one of my "students".

02 February 2005, 11:00 PM
Ok. This is the link to the file. Mind you, it's a 34 MB scene when you decompress it and it's made in Maya 6. Try to do this:

Above the character there's a sphere - that's the control object. At the head and feet there are 2 locators. Try to add a new attribute to the sphere and try to animate the translations of those locators through that attribute. Now this is what I get:
The base keyframe (when the attribute is 0) hooks up fine. I then change the attribute to let's say 10 and move the locators to a new position and set a key - also works fine. The problem occurs when I change the value of the attribute to let's say 20, move the locators and set a key. Now try to play with the value of the attribute and you should notice that the last position changes. And if you try to add yet another key, you'll get the same result.

CGTalk Moderation
02 February 2006, 12:01 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.