View Full Version : MRay Satellite setup problem!

02 February 2005, 09:42 AM
Hi guys,
So thats the problem - any time i start the render from within maya and have some host set in maya.rayhost, the render just freezes. In the output window there is a message "... Adding host" for example and thats it, nothing happens. I`ve tried changing the port from the default 7103, tried changing the master machine also, but nothing gave me any result... I think that might be a network issue, but cant know for shure.
Any help will be highly appreciated. Thanks in advance guys...

02 February 2005, 01:31 PM
Well, that sounds a bit blurry to me. Have you set up any firewalls? Are you able to ping the slave machine with the given IP at least? How does your maya.rayhost look like?
A little tip: always write the port along with the IP in the .rayhost file, e.g.:
But didnt the protocol change with mr 3.4? Usually the last digit of the port number indicated the version, so for mr 3.2 it was 7002 or something, for mr 3.3 7003 and so on.
Some hints:

02 February 2005, 02:14 PM
Thanks for the reply Floze...
There was a firewall on one of the machines but i removed it to test the network render. I have no problems ping-ing the slave machine... Everything looks perfect but the render just doesn`t start (it hangs saying "....adding xxx host...", but start right away i shut down the raysat service on the slave machine)
For the port number - in MRay for Maya Satellite the default port i 7103, but i dont think thats essential, u can use any port u like as long they are the same on both machines...
Thats the maya.rayhost file content:


# Copyright 1986-2002 by mental images GmbH & Co.KG, Fasanenstr. 81, D-10623
# Berlin, Germany. All rights reserved.
# Evaluated at startup time of the plug-in to find ray servers for the
# integrated mental ray renderer.


Another thing that bothers me is that when i run "netstat -n" while the machines are trying to connect it gives me this result: ---> ESTABLISHED
You see the port of the master machine is not 7103, i changes every time I try to make connection ( the manual says the ports should be the same)...

Sorry if my explanetion of the problem is a little bit confused, but i`m total network lame, hope u understand :shrug:...

02 February 2005, 02:22 PM
For the port number - in MRay for Maya Satellite the default port i 7103, but i dont think thats essential, u can use any port u like as long they are the same on both machines...yes, but they have to match the one on the services file (win->sys32->driver->etc->service).

also did you made an account for the raysat service ? try to do one with the same credentials as the master that is connecting to it.


02 February 2005, 02:28 PM
I also remember you need to have the msvcp70.dll or msvcr70.dll (or both?) runtime libraries located in your win\system32 folder. Do a google to get them somewhere.

02 February 2005, 03:30 PM
No succes, still hangs... I tried the dlls ( one of the machnes was missing msvcp70.dll) and created accounts for the raysat.... Can it be a network setup issue?

CGTalk Moderation
02 February 2006, 04:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.