XM Magdalena 3D print, GGeorgy (3D)
LC #42 Pipers Alley

View Full Version : Softimage Beginers Tutorials

12-06-2004, 04:49 PM
Hi, just moving from Lightwave to XSI. I'm working through the beginers tuts' off the softimage site and I've come accross my first frustrating problem:

In Tutorial 1: The Basics of Working in XSI—Cobblestone Alley, I am trying to apply a scale transform value on step 6 of Randomize the size of the boxes:

"6. On the Transform panel, enter r(0.7,1.0) in the Scale Y axis text box and press Enter."

When I type the formula r(0.7,1.0) in the Y text box and press enter I get the Windows Dong that nothing has happend, hence the transform doesn't work. If I enter 0.5+ then the scale transform works as expected.

My first guess is that the formula r(0.7,1.0) is a misprint in the tutorial, or it no longer works this way in v4.2 but it could just as easily be something I'm doing wrong.

Has anyone else had this problem?

12-06-2004, 05:47 PM
it still works that way.
make sure you OS settings use . for decimal separators and , for unit/hundreds separators.

12-06-2004, 05:52 PM
I hadn't thought of that, but the OS is set correctly that way. So if it should still work that they then it must be something I am doing wrong. I've already tried it again from the begining and I still get the same problem.

I hate it when I can't work things out!!!

12-06-2004, 06:11 PM
did you try in a fresh scene?
just creating some cubes and doing it.

also if for any reason you animated the scaling the technique is obviously going to fail as soon as the animation kicks in, because it's going to reset the scaling to whatever the animated value is.

12-06-2004, 06:29 PM
Just tried a new scene, created a cube primitive and then tried the r(0.7,1.0) formula in the Scale Y text field. Nothing happens, windows error noise. But if I type 0.5+ in the same field, the height of the cube increases as you would expect. I'm using the v4.2 Foundation 30day trial. This should work right?

12-06-2004, 06:37 PM
I just tried the r(#,#) function in 4.2 FND and all still works fine for me.

12-06-2004, 07:03 PM
I have to type in r(0,7;1,0) to get it work (Win XP German). Try a different value separator like semicolon ";"


12-06-2004, 07:11 PM
I have to type in r(0,7;1,0) to get it work (Win XP German). Try a different value separator like semicolon ";"

that's why I was asking about the separators.
it's always wise to change your international settings to US (this doesn't affect your keyboard layout) since that's what most programs assume you'll be using.

you'd be amazed at the kind of instability and error-prone processes I've seen fixed by this simple change :)

12-06-2004, 07:56 PM
I tried the ; seperator and made no difference, but I guess it has to be something to do with the international settings and what my OS thinks is a seperator.

So I changed all my date/time settings and location to US, but then my 30 day eval version would not start up, I guess its using UK date format to track how many days I have left. I think I'll test a few seperators and see what happens.

I've ordered Foundation today, so hopefully it wont take long and I can try the US settings when I have a license key. Its no big deal, theres plenty more tutorial for me to get through. I just hate it when something beats me!

12-06-2004, 07:57 PM
Oh and I forgot to say thanks guys for your advice :)

12-06-2004, 09:00 PM
Ok, cracked it! rork over on XSI base gave me the idea.

I tried a simple r(1,2) and it worked. Then to make sure I tried the r(0.7,1.0) again, didn't work. So then I tried r(0.7,1) and that was it! I guess it just didn't like the 1.0

CGTalk Moderation
01-20-2006, 03:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.