View Full Version : Materials applied to clusters not working when rendered

11 November 2004, 05:31 PM
Using Softimage 4

I have a character with different clusters for the trousers and skin etc. When i apply a material to any of the clusters all i keep getting is the standard shade of grey. The colours show in the viewport but not when i do a quick render.

Would this have anything to do with the fact that the other meshes that i'm using for the shape keys to drive the facial animation do not have the clusters for parts like the trousers?

11 November 2004, 05:44 PM
Generally you should avoid working with different materials on clusters, especially in renderpasses it is problematic.
I have not heard that blendshape should mess up the materials on clusters, but blendshapes are clusters themself so maybe thats why they tend to screw up.....I dont know..


11 November 2004, 08:22 PM
i had this problem and i solved modifying the cluster order...

11 November 2004, 09:04 PM
Are you using partitions or overrides? If you are, you may need to put your clusters in groups and apply the material to the group. This will be properly over-ridden in the pass then.

Even if you've kept a relation, I can't see the other shape targets effecting your mesh at rendertime, so I doubt that's a factor. You could always freeze your object and do a test render to confirm though.

Oxyg3n, are you just talking about dragging in the explorer to reorder?

11 November 2004, 09:06 PM
i don't know if it's the same thing, i changed the sort order from pt ppg and worked

11 November 2004, 09:16 PM
btw, i hope i didn't messed up anythnig alse by changeing the group order... the mesh in enveloped, has syflex op and several objects are cluster contrainted to the mesh

11 November 2004, 12:41 AM
Thanks oxyg3n^

Changing the cluster order fixed it.


11 November 2004, 01:07 AM
Would anyone kind enough to elaborate what does it mean by changing the cluster order? Thanks.

11 November 2004, 08:39 AM
Well i'm not quite sure what its used for but what i did was...

Select a cluster then press enter to bring up its options. At the bottom there should be a order number. I swaped a few of my cluster order mumbers around.

CGTalk Moderation
01 January 2006, 12:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.