View Full Version : a question about Mindthinks - extrude along normals

11 November 2004, 01:46 PM
Hi, Does anyone know if this plugin (Mindthinks - extrude along normals) works well in xsi 4.0? MT_EAN if im not mistaken is the correct command. I select polygons or edges, click the command... and it does nothing.
This command supposingly does the same like Lw smooth shift... it can even be used to extrude edges.

thanx in advanced

11 November 2004, 02:02 PM
Unfotunately the latest word from 3D-Tutorial is that Mindthink Tools v3.0 doesn't work with XSI-4.
They are hoping to bring out a version that is compatable, but no firm date as yet.

11 November 2004, 02:40 PM
Hi, I'm using Mindthink 2.01, tried most of them can be used, except MT_EAN. I see some of the tools are already in XSI 4.0 so it's develop before v4.0 came out.

and if i'm not mistaken Mindthink v.3.0 is not for free

11 November 2004, 03:19 PM
send an email to helge asking him if he doesn't mind his script to be modified.
if he gives green light post it in the thread or send it my way and I'll see if it can be converted to work with v4.

11 November 2004, 03:36 PM
Great! thanx ThE_JacO, i'm asking him now...:)

11 November 2004, 03:56 PM
Mindthink 2.01 Extrude Along Normal works fine for me with XSI 4.

THe only problem (not really a problem) I have is that many tools have double options boxes displayed. Anyone know how to turn it off??

11 November 2004, 04:30 PM
Very weird. It does nothing for me.

Could I miss something during the installation of the plugin? because some steps from the website dont make sense to me.

7. Run the reg.bat in the bat-subdir of the addon.
8. Install the all SPDL files (in the spdl-subdir of the addon.
(Use File->Addon->Plugins(SPDL))
I missed these 2 steps, there's only 1 file, which is "mindthinktools2.01.xsiaddon" and can only be installed from file - addon - install. Anyway I'm already able to use the other plugins from the custom toolbar except for MT_EAN which is the Extrude Along Normals

Is there anyone else tried the MT_EAN from mindthink 2.01?

jaredL - have you tried Solidify2 as well? because i have problem, that it does not appear in the custom toolbar - available commands (I think i've installed correctly from File->Addon->Plugins(SPDL))

ThE_JacO - Do you get MT_EAN works on XSI 4.0 before?

sorry for this noob question. Thanx

11 November 2004, 05:48 PM
Hi everyone, I've found Ctrl+D -> Deform - Push, does exactly the same in any condition just like Extrude Along Normals (lw smooth shift) not in 1 click, but that's okay.


11 November 2004, 11:41 PM
I'm glad you guys brought up the Mindthink topic because I now have stuff working that didn't before(and I didn't really know it since I hadn't tried it much yet :-)). It turns out that the steps mentioned are pretty important or a few things aren't enabled. I found the bat file(and ran it) in my "Craig\Softimage\XSI_4.0_Foundation\Addons\MindthinkTools2.01\bat" folder and there were files in the spdl folder that I had to add using File/Add-on/plugins(spdl). This brought up a dialog box that listed user plugins- in my case none. I then selected Install and browsed to the spdl folder and installed each spdl file one at a time(multiple selecting and installing didn't work). I now have some new commands working- the ones that needed the spdl files. :-) BTW, the EAN gives a different result than doing a copy and push so it's not exactly redundant- it scales a poly as it extrudes.

11 November 2004, 05:52 AM
Uumm ... as i mentioned before, There is only ONE file which is the "mindthinktools2.01.xsiaddon" that was given to be downloaded... No sub-dir, reg.bat, or anything like that. That's why it didn't work properly

CraigT, I'm glad if you can point me where to get the complete files ... Or even better if you can email it to me

11 November 2004, 08:11 AM
The only file I had downloaded was a small "" which extracted to the same file name except ".xsiaddon". I then went to the File/Add-on/Install menu and browsed my way to the "mindthinktools2.01.xsiaddon" file to install this file. This apparently installed all the scripts and created the folders I mentioned, including adding the spdl files. XSI is new to me so I don't have any idea of how it handles scripts and plugins yet but unless I forgot something, my two posts should get you going. Remember, I only downloaded the one file myself. I have a feeling you do have the files on your hard drive but just need to install them since you mentioned some scripts worked apparently. Try doing a search on your C: drive and also the xsi folder(if on another drive) for *.spdl and reg.bat. This should get you pointed in the right direction.

11 November 2004, 12:36 PM
Hi CraigT, my bad, it was installed in user add-ons which is under the users/ dir. I was looking for the sub-dir in softimage/addons (which is the factory add-ons). Everything installed properly now, and like you said EAN works nicely. :bounce:

thanx to you mate!!

11 November 2004, 04:40 PM
Glad to help and to hear you got it going. I found the whole thing a little confusing myself but I don't have a good understanding of how XSI does things yet as compared to Lightwave and MAYA. I sure do love XSI though, even the Foundation version- haven't fired MAYA up since I got it. :-)

11 November 2004, 06:02 AM
Although xsi approach is not as straight forwards as lightwave, but the more i understand it, the more i love this program and start to understand why xsi does the way it does things. Definitely worth investing the time and money.:)

11 November 2004, 11:52 AM
never used MTTools sorry, since v2 I've always been fine with the default tools +RCtools and some of my own stuff, since v4 I even forsake RCTools and most of my own set.

as for duplicate+push try selecting polygons and use extrude along normals, with v4 it has an inset parameter, it could save you a click and it's often closer to what you'd like to do then push is since the inset can be setup in different ways (locked/unlocked, proportional or absolute etc.)

CGTalk Moderation
01 January 2006, 11:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.