View Full Version : Driver file match, yet no go! WHY?!!!

10 October 2004, 05:51 AM
What to do when the requested driver file DOES match the name of the provided file, YET, Windows2k tells you "it was unable to locate a driver"?

Thanks a million,

10 October 2004, 06:28 AM
Did u replace a specific file, or reinstall the driver? if the first, reinstall the whole drive, not just replacing the missing one. Perhaps it installed faultely

10 October 2004, 06:59 AM
This is a driver for the onboard sound of an old pc I have to get up and running.
I think I found the right drivers just moments ago.
It still puzzles me the original problem though.


10 October 2004, 09:58 AM
Look at the video chip on the motherboard. There will be a model/make number on it. Write it down and go to and see if you can match it to a driver.

Otherwise, try googling it and see what comes up.

10 October 2004, 11:09 AM
Your old driver could be corrupted. If you still have it, do a file compare with the new one that works (if I have understood the thread correctly).

10 October 2004, 07:36 PM
Ok, I'll tell exactly what I'm doing so should there be something odd you can spot it.

I downloaded and tried two set of drivers from their site: (
But like I said, they are both giving me the mismatch restults I mentioned before.
According to Belarc Advisor, this is the model name of my mb: M756LMRT 1.0

And these are the links I found to be the most likely to match my mb:
M756+ (V5.3)
M756L+ (V5.3) - especially this one
from here:

Well, I tried both and the sound still not working.
I have tried both installation ways: using their Setup.exe, and using the Hardware Wizard.

Any ideas?

10 October 2004, 09:55 PM
Ok, maybe the problem is on my side, I mean to say, on the way I am doing things. So I will provide some more info on that this time around:

Once I get the drivers I go to the Device Manager, and go to the thingies that show in yellow with a question mark. There are 2:
1. Multimedia Audio Controller, and
2. PCI Simple Communications controller

I then open the properties of the M.A.C. and click Reinstall Driver (in the General tab), and proceed to find the driver file I just downloaded.
Also, I have used the Setup program that comes with the drivers.

Same thing goes for #2 above.
What am I doing wrong? Isn't the MAC the right thingy to provide the Audio driver?

You won't believe how the sound driver was found! I allowed the Hardware Wizard to look in the internet for an update, and it found it!

Unfortunately this didn't work for the PCI Simple Communications controller, so I would still appreciate it if someone can enlight me .


CGTalk Moderation
01 January 2006, 02:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.