View Full Version : Windows XP Admin Access Denied

10 October 2004, 05:50 AM
Okay, so recently, because I couldn't boot for some reason, I had to reinstall windows entirely. This always sucks, as I have to reinstall all my programs and everything, but that's not that bad. However, I stored almost all my files in the my documents of my password protected admin user on previous Windows XP install. Now, on my new install, even as admin, I can't access the files. Initially, I searched google and someone said something about how the files are gone, but I refuse to believe that because when I try to access the folder in something other than explorer (i.e. windows explorer), I can often browse and see all the correct folders and everything (though I can't see the files) in that old user's documents, so it seems to me pretty unlikely that the stuff in there is lost.

Is it possible that if you have an admin, only that account (not even later admin accounts) can access that folder? Or might I have had some software on my previous machine that protected it (I never used any encryption software, though Norton Antivirus might be possible of that)? More to the point, how can I get those files back?

[me whining]
The files are not ESSENTIAL; not business related or anything, but you're looking at hundreds of hours of work that it took to get all the files... maybe even worse I was temporarily holding about 5 GB of iTunes songs (1800 songs) that my friend needed me to hold on to because he didn't have enough space - I don't want to owe him the money to buy all those songs again, and I REALLY don't want him to hate me. I have had to format my HD before, losing all my files without backup, but these are much more valuable to me by comparison. Once this whole thing is over, files gone or not, I am absolutely investing in a backup HD.

To summarize that whining, any and all help would be unbelievably appreciated.

10 October 2004, 06:02 AM

Please refer to the above thread. The guy with the advice already got banned but the guy that helped is still around. Maybe he can tell u how to get those files back (I hope his advice wasn't what got him banned).

10 October 2004, 06:34 AM
There is another way, which may be a little complicated but could work. Download a real simple version of Linux, maybe Mandrake since it has the nice interface if you're not used to Linux. Install the most basic Linux installation, but keep it set so you have the choice to dual boot into Linux or Windows.

When installing, there is an option for how to split your hard drive up with partitions. Usually it should show your Windows partition. It shouldn't, but make sure it doesn't delete your Windows partition, because then you would lose your files.

Anyway, after Linux is installed, go to the Windows Administrator folder where all your files are. Then copy these files to a folder that can be accessed by anyone when you boot up in Windows.

Boot back into Windows, and your should be able to access your files in whatever folder you copied them to.

Back up your files on another harddrive, and completely re-install Windows again.

10 October 2004, 08:17 AM
It has a NTFS read option for its dos boot disc, hopefully you'll be able to navigate to your directory and copy all your files somewhere you can get too.
Hope it works.

10 October 2004, 11:51 PM
Thanks a lot guys, I'll try that stuff and let you know how it goes.

As for Linux, well, I installed Linux only about a week ago and it might have even been what screwed up the Windows boot for some reason. I tried to get an NTFS driver for it, but the NTFS driver didn't work (I think cause I was using x86-64 linux, I have an AMD 64 machine), but I may try 32-bit linux.

But yeah, I'll try that stuff.

10 October 2004, 12:45 AM
STOP! Don't mess with linux or any of that junk.. The problem is that the GUID of the admin account thats attatched to that folder is different from the GUID of the current admin account from your reinstall. To remedy this, do the following:

Open "My Computer" - Tools - Folder Options - View - Scroll to the bottom and deselect "Use Simple File Sharing" - OK back out to My Computer

Right click on the old My Docs folder thats giving you problems and click on "Properties" - "Security" - then "Advanced" button at the bottom.

In the Advanced Security Settings window it should be blank or list some random characters for a User. You can ADD your admin account under "Permissions" or Click on "Owner" tab and in here you should get a popup asking if you want to take Ownership of the folder (as an admin, you can always take ownership).

To add a user: Click ADD - Advanced - Find Now - drill down to the admin account, click it and then OK back out.

This will fix the GUID on the folder so you can access it and delete the old corrupt admin account on it. And when your done, you can change XP back to "simple file sharing" otherwise, unless your familiar with working in a windows 2k(2k3) domain environment, sharing will be kinda hard for you :P

*Side note, you might have to give the Admin account full rights after you give it ownership. I don't have a corrupt folder to test this all on so I don't know the specifics. :P

10 October 2004, 01:58 AM
NOVACOG, please post back and tell us if what SIEB said worked.

I had previous instances wheere I didnt' know how to access files like in your situation. I don't have anyway to test that technique out now, but would live to know if it actually works for future problems with Windows.

10 October 2004, 03:21 AM
NOVACOG, please post back and tell us if what SIEB said worked.

I had previous instances wheere I didnt' know how to access files like in your situation. I don't have anyway to test that technique out now, but would live to know if it actually works for future problems with Windows.
Same here!

10 October 2004, 04:45 AM
Oh man, I only have Windows XP Home, it doesn't have the option to turn off "use simple fire sharing". *Sigh*, okay, any discrete way to do that in WinXP Home? Or do I have to upgrade to Pro (which I am perfectly willing to do, I should probably do it anyway)?

EDIT: You know what, I'll upgrade, I oughta make a stop at Fry's anyway (I know it's not the best deal on it, but I want it fast). Thanks a LOT Sieb, if this works, I will be in such incredible great debt of you. On the chance that it doesn't, I wanted XP Pro anyway.

10 October 2004, 05:25 AM
It works with Home also, you just have to login under safemode as the admin in order to access the Security tab. (I had to look that one up, never use home so wasnt sure)

yes, it works, I have had to do it a few times on servers after reloads. After reloading a server that has data on seperate drives, you have to take ownership in order to update the GUID's on the files (that is, if your using NTFS). Don't believe me?;en-us;308421&sd=tech


10 October 2004, 05:34 PM
Yeah, I had already read that Microsoft thing actually, when I said "on the chance" I really meant "on the very very off chance" ;) . I haven't gone to Fry's yet (just got up), but you know, I really really oughta have Pro anyway, and currently I'm not pressed for money, so it's all good. Again, thank you SO SO much.

Edit: Btw, just so you know, the safe mode way DOES work, and thank you SO MUCH.

CGTalk Moderation
01 January 2006, 02:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.