View Full Version : Bandsaw

10 October 2004, 01:03 AM
When i try to use bandsaw i get the message "custom operation failed Cannot load external plugin file <C:/lightwave/plugins/model/BandSaw.p> What should I do?

10 October 2004, 02:13 PM
Turn off all the other layers of your object.

10 October 2004, 02:34 PM
It the same with most of Di's Tools (SuperShift, etc.)

BTW, the authour, David Ikeda, is promising an awesome update to KungFu Tools any day now...

10 October 2004, 08:28 PM
Thanks for the help. I tried turning off the other layers, but it still didnt work. I think it might be happening because I am missing the file. I am gonna try reinstalling lightwave.

10 October 2004, 09:41 PM
Yes, and No, if you have multiple layers selected, you get a different error.. which if I remember correctly is ... "Select a polygon of 4 point patch". In that case you need to turn the other layers off and isolate the one you are trying to use the bandsaw operation on.

The error you are getting is that Lightwave cannot find the bandsaw plugin. Depending on which version of LW you are using, go to the add plug-in dialogue, and add the bandsaw.p plugin (it will be in Plugins/modeller directory). LW will then tell you it found the plug in, and you should be able to happily use it.

Do not reinstall the app for a missing plugin. Just re-add the plugin. Once it is in, close LW and start it again, so the plugin association is saved in the config.


10 October 2004, 10:31 PM
Igu4n4, i just tried adding bandsaw but i couldnt find it in the plugin folder. There were no files in the plugin folder. Do u think it could have been deleted?

10 October 2004, 10:54 PM
which version of lightwave are you using? if it is LW 8 it *should* be in.. Program Files\Lightwave [8]\Plugins\model\bandsaw.p ... actually should be same for Lightwave 7. (of course if you didn't put it in the Program Files folder it will be wherever you installed it.

If you have NO, zero, nadda plugins in your plugin folder then you have a bad installation or you deleted them accidentally somehow. Remember that almost all functions in LW are brought in through plugins, so if you have no plugins in the plugin folder LW should pretty much not work at all for you. In which case you would have to reinstall the application. But ... they must be there.. somewhere aren't they?


10 October 2004, 11:05 PM
thanks for the help igu4n4. I am using lightwave 7.5. I have a bunch of plugins in the legacy plugin in folder and the lscript folder but none in the plugin folder. I think they must have been deleted because i was using bandsaw a week ago or so.

10 October 2004, 01:17 AM
okay well.. last this..

-Open up modeller
-go the modeller pulldown (under File)
-select plugins->edit plugins.

(this will open up the edit plugins dialogue)

-change the grouping method to "File"

You will now see all the plugins LW Modeller has loaded and where they are.

If you do NOT see any plugins here...

-select the Scan Directory button
-select the Model directory in the Plugins in the Lightwave folder.

**(If you put your plugins in a different directory select that one, by default they are in the Model directory)**

This will load every plugin in the Model directory.

It SHOULD say... xxx number of plugins found in xxx number of files.

Once it's done this.. hit Done, close modeller, and open it up again. Go back to the Edit Plugins menu and change group type to File again, and see if it loaded Bandsaw. (or any others you are missing).

IF NONE of this WORKS.... yer screwed ;P Reinstall LW from your original disks, and update it again.

**actually if you're ONLY missing bandsaw.p, you might be able to just copy the file from the LW installation disks to your plug-ins directory and add it like you normally would ... I can't remember off hand if the files are in cab files, or if they are in directories on the Install disks**

annnnd.... that's all I got.


10 October 2004, 03:49 AM
Thanks. I copied all of the plugins in the plugin folder from the disk to the empty plugin folder on my computer and it seems to be working fine now.

10 October 2004, 04:50 PM
ya I couldn't remember if they were loose files on the install disk or if they were in a self contained .cab file. Either way.. glad you got it working... Bandsaw away!


10 October 2004, 04:51 PM
ya I couldn't remember if they were loose files on the install disk or if they were in a self contained .cab file. Either way.. glad you got it working... Bandsaw away!


*Edit Oops dbl post*

CGTalk Moderation
01 January 2006, 01:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.