View Full Version : mouse installation question

09 September 2004, 02:12 AM

I recently bought the Evoluent mouse (the older version) for a laptop (running XP Home) w/a USB port that several people on this site recommended earlier. I'm confused on how to get rid of the driver for the traditional mouse I have (Memorex). I don't remember having to install them myself I think XP Home found it the new hardware and the only driver I can find seems to be the one that controls the touch pad mouse (which I don't want to lose).

Wondering what I may be missing in this process?

Thanks for any suggestions.

Rabid pitbull
09 September 2004, 03:50 AM
Is there a uninstaller listed in the uninstall programs control panel? Might have forgotten about installing it. Next you could look at the startup and installed registry listings. Regcleaner is great for this, but be careful and make sure you know what you are getting rid of. Google any unknown listings for help deciding.

get regcleaner here:

09 September 2004, 03:45 PM
Thanks for your reply.

I can't find the uninstaller, maybe cause I'm running XP Home and that is more visible in Professional? Just want to be sure not to remove the touch pad driver (which is the only one I can find listed). I tried installing the mouse w/o removing any drivers and it isn't being recognized the way Evoluent instructions say it should.

Thanks for recommending the regcleaner. I will take a look at it later. Looks like it would be helpful for me to have beyond this installation.

09 September 2004, 06:48 PM
...but looks like I will still be in danger of losing the the touch pad capability.

Any suggestions for me?


Rabid pitbull
09 September 2004, 07:25 PM
Did you go into the device manager and try to uninstal the old mouse?? Only other option is contacting new mouse company directly if possible. :shrug:

09 September 2004, 03:10 AM
I believe the PS/2 driver stuff in the registry is found under...


But, don't change anything in there unless you know what you're doing. I wouldn't know what to do with that, if even you should, but I believe that's where the registry keys are located that control that. At least some of them. Someone correct me please, if I'm wrong.

The situation described in this ( link isn't exactly yours, but it's kinda simliar. I thought I'd post it and see if anything in there helped. Check out this ( one also. Someone at another board had a simliar problem.

I'm sorry if that's of no help... but I hope it is. =)

09 September 2004, 02:33 AM
Thanks for the links and suggestions.

I've bookmarked them and will take a look at those. Yeah, I may have to contact the company as unfortunately, I don't have regular access to another machine to be able to risk temporarily losing the touch pad capability due to my lack of knowledge. I was just hoping someone on here had tried installing the evoluent mouse on a laptop under similar circumstances since it is more common to find people looking for mice w/additional buttons here.

Rabid_pitbull, do you think removing Alps Touch Pad of Type "Mice and other pointing devices" will affect the touch pads on the laptop?

Thanks again all.

09 September 2004, 02:54 AM
Windows XP comes pre packaged with many drivers already for all sorts of things (one of its big selling points when it came out). If windows never asked you for the driver install, it most likely already had the driver for that mouse. Or at least a generic one that worked.

And Alps Touch Pad of Type "Mice and other pointing devices" sounds like the touchpad, so I wouldnt remove that.

When you tried to run the new mouse's install program what happened exaclty? How does the setup manual tell you to install the mouse? If you plug the mouse in does it work? (without installing the drivers)

09 September 2004, 02:56 AM
Andyman, appears I have to pay to see the solution at that second site? Is that correct?

09 September 2004, 03:12 AM
And Alps Touch Pad of Type "Mice and other pointing devices" sounds like the touchpad, so I wouldnt remove that.

Yes, exactly why I've been so hesistant.

Thanks for your reply

Yeah, as I mentioned above, I did try plugging the evoluent into the USB w/o removing the driver and nothing happened. (I did remove the memorex mouse physically prior to doing so).

The page for setup says to remove the drivers of the old mouse first and then install the new one into the USB port while the machine is on/off and then insert in the CD after Add HW wizard runs. Do you want to know what options they tell you to select from the wizard?

09 September 2004, 03:20 AM
Well ok when you put in the mouse nothing happens? the hardware wizard didnt pop up? No little bubble poped up in the corner of the screen saying new hardware found?

Could you give me the exact name of the mouse?

09 September 2004, 03:26 AM
No, the wizard itself definitely did not pop up and I don't *think* I saw anything else either. Perhaps I will try again though now that you mention just to be sure.

It's a Memorex MX4100 PS/2 mouse.

Thank you.

09 September 2004, 03:40 AM
What is the mouse you are trying to install?

09 September 2004, 03:42 AM
The evoluent vertical mouse (the first one), not the latest.

Let me try again and see if the bubble pops up.


09 September 2004, 03:48 AM
Andyman, appears I have to pay to see the solution at that second site? Is that correct?
Yeah I know it says that, and I honestly don't know what that does because I didn't even click on it. Just scroll down to read the rest of the messageboard discussing that took place there.

Rabid pitbull
09 September 2004, 04:06 AM
Thanks for the links and suggestions.

Rabid_pitbull, do you think removing Alps Touch Pad of Type "Mice and other pointing devices" will affect the touch pads on the laptop?

Thanks again all. Yes it sounds like it wouls disable the touch pad. Is it the only mouse listed?? I would try plugging it in again and watching if anything happens, if windows does not recognize it maybe the device is damaged.:sad: If that is the case you should contact the manufacturer by telephone if possible.

The other thought I had was that maybe the usb slot is damaged(hope not!!), do you have any other devices plugged in to the machine? I have also encountered problems with scanners and printers being so power hungry that other devices will not work on same slot pair with them. I have never had one be unrecognized but if it doesn't power up maybe this is a cause. Try unplugging everything but keyboard and then plug in the mouse.

For some reason I forgot this was a laptop.... now I have seen that some laptops have several usb ports, pretty common I have seen some that seem to have ports with less power to one or more. I say this because I have seen dongles not work unless in certain port. Try plugging the mouse into every port available to see if it is recognized on one instead of another.

09 September 2004, 12:22 AM
The problem turned out to be a lot easier to solve. There's a usb->ps2 converter that came w/the mouse. I tried using that instead and was able to install the drivers on the CD w/o having to remove the standard mouse driver at all. In fact, I'm using the evoluent mouse now. So, trying to plug directly into the USB port was just making things harder. However, if there's a reason to do so, another suggestion someone gave on another board was that I could got to the PC manufacturer's Web site and download the original mouse driver first as a precaution.

Thanks everyone for your suggestions. Still not entirely sure why it seems to have worked so much easier to use the converter but I'm glad since most of the printers now hook into the USB ports and I only have 2 of those. And, yes, as others on here have said, it does seem a lot easier to track and dolly in Maya with the additional button on the mouse too (other than the ergonomic design).

Rabid pitbull
09 September 2004, 06:05 AM
glad you got it to work!.:thumbsup:

09 September 2004, 02:16 PM
windows was probably using a generic plug and play driver for the older mouse. All you had to do was run the cd that came with the new mouse and it should have worked. You could probably use it in the ps/2 port at this point too.

CGTalk Moderation
01 January 2006, 05:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.