View Full Version : MentalRay final gather issue?

Dan Wade
09 September 2004, 11:45 AM
Im rendering a scene in Maya with mental ray. I seem to be getting black splodges (non technical term, lol) on my renders. Im sure its some sort of final gather issue. First i thought it was a memory problem, some of my early tests were using more RAM than i had, but my current scene only uses about half of my memory, and the problem still persists. Not a clipping issue either, checked my cameras out. Here is a pic of what im getting. Any ideas folks?


09 September 2004, 12:07 PM
Dan, boy that looks horrible, final gather moss eh:scream:, I have never seen anything like it, do you have any lights in your scen. with an intensity value? perhaps its a shader issue, does render diagnostics show anything?


Dan Wade
09 September 2004, 12:12 PM
Well, the thing is, for the last couple of hours, this has been rendering fine, with the exact same settings. render diagnostics dont pull anything up it seems. Small lesser blacks dots seem to appear even on renders with final gather turned off....hmmm...v odd. Its not the camera clipping planes either. Ive tired up the settings for antialiasing and my BSP settings for MR, but still no luck.


Dan Wade
09 September 2004, 12:43 PM
Just tried using brand new cameras, even importing everything into a new scene, still getting the same errors. Anyone got any ideas?


09 September 2004, 02:43 PM
I had a similar problem except the black spots were squares and werent quite so big. It turns out it was an object that I created from nurbs then converted to sub d's then to polys. Its UV's were all messed. After creating a new set of UV's for the object the black spots dissapeared. Have you created any new objects for your scene recenetly?

Dan Wade
09 September 2004, 03:19 PM
Just tried the UV sugestion, still no luck im affraid. The worst bit is, the errors dont seem to be consistant, so its hard to nail down what the problem is. Somtimes i could just change the texture, and things would work for a few renders, then mess up again. Just bumping up my BSP settings, still nothing.


Daniel Whitton
09 September 2004, 05:11 PM
Had same prob to. I was using the Dirtmap shader, mmm.
Also I have seen threads with similar issues using Maya Area Lights.

09 September 2004, 05:30 PM
better not use the Maya default area lights, try to create a point light, and then convert into a MR area light with a square projection or any projection you need:thumbsup:

02 February 2005, 08:45 AM
i have an excellent pic of final gather blobs. Let your imagination lose and tell me what this looks like to you.


02 February 2005, 03:27 PM
Uhm, well, this could sound really stupid, but it worked for me a while ago (even though I wasnt getting such terrible blobs, just some black spots which seemed to be appearing randomly). I was following a fg tutorial and it said like a very important thing that you should turn the default maya light off. Im kinda sure you have already done that, but I mention it anyway just in case. Hope it helps!

02 February 2005, 05:39 PM
I have never seen this before but here's my two cents. Since most of the blobs happen on walls that would require a number of bounces to get to or in the test tube scence, sides that would require tracing through a number of layers to get to, I would try experimenting with the number of raytrace reflections, refractions, trace depth and the shadow trace depth to higher values. Also this is a golden opportunity to learn about the diagnostics MR has to offer in its globals and also looking at the Map Visualizer. Since it still happens without FG and you accounted for approximation and UVs, my guess is that it's a raytracing issue. Turn it off and see if your problem persists.


02 February 2005, 06:15 PM
i have an excellent pic of final gather blobs. Let your imagination lose and tell me what this looks like to you.


hah... thats a pretty good artifact... they're bumping uglies!

Dan Wade
02 February 2005, 02:54 AM
Its pain in the bum isn't it?

Ive been on the Mental Ray forum for quite a while now. There are basicaly lots of things that set it off, from what i gather raytraced area lights are one factor. This is a noted MR error for Maya that both Mental Images and Alias are aware of. I know its no consolation, but it is fixed in maya 6.5's version of Mental Ray 3.4. Maya 5 was also fine. Must just be something wrong with MR 3.3 in Maya 6.


02 February 2005, 04:51 AM
dont you guys think that it looks like a guy pinning a girl down doing you-know-wat ...

i deleted my lights and recreate the lights then it was ok

02 February 2005, 06:51 AM
dont you guys think that it looks like a guy pinning a girl down doing you-know-wat ...

BHAAHAA..Now that you mention it!

I've had this problem before and there werent any Maya area lights in the scene, only mr area lights. I fixed it by creating a new empty scene and importing the messed up one into it. Seemed to get all those weird bugs out.

02 February 2005, 11:23 AM
i had this kind of bug in various situations so it is not related to only 1 kind of light, geometry or else.

it seems that when you do some kind of operation, you just lose some info that is not rebuild by maya. the result is wrong results that cause Mr to give you these black dots...

the only work around is to as soon as you notice that kind of artifacts in your renders, just undo what ever you where doing to the point that those disapear, or rebuild evrything till it appears again and isolate what went wrong so you can find a work around...

i know this isnt much of help, but thats how ive been getting away from this bug...

good luck

02 February 2005, 11:59 AM
I ran into a simliar issue that previously was fixed by deleting the lights and recreating them. This time however it had to do with the mesh of the object I was rendering. Basically our programmer had to write a script that would export all of the verts for the information and re-import them back in and rebuild the mesh from scratch. It had to do with either Byrons or MJTools causing the mesh information to corrupt (can't remember which but we've since abondoned use of both simply due to the sheer amount of problems both caused in a production environment). That ended up fixing the issue. This was in a traditionally lit scene, no final gather and no GI, just rendered with mental ray.

02 February 2005, 02:54 PM
If you run into problems with your mesh (e.g. screwed normals or st. similar) it might help to export it as dxf and reimport it. My two cents! :)

03 March 2005, 07:17 PM
I had this exact problem...big ugly black circles. I finally narrowed it down to shaders that had been made with previous versions of maya I had gotten off of highend3d.

03 March 2005, 08:09 PM
I have hadthe same problem quite frequently, but in true Maya fashion, mine have seem to come from the shader side. I could easily get rid of the problem by just changing the connections I was making in my shader groups. Here are a few of common things that i experienced those artifacts showing up on: (and this applies to all types of geometry in my scenes and regardless of light type, Final gather did seem to make its appearance more frequent though).

The most frequent occurance was when I tried to use a phong E (or any maya native shader) as a specular/reflection layer in a mix8Layer node over top of a mentalray specific node, like an mibLambert or Madvelvet. I never really played to see if the transfer mode had anything to do with it. I just always found mixing maya nodes over mentalray nodes to be the most frequent cause. When finalgather was on if I was mixing any maya nodes on top of a mentalray node it always happened, although if I replaced that phone node with say a DGS it wass fine. Also if the MibLabmert was pipe into the color of that PhongE, that also worked fine, it just didnt work when I tried to layer them. So for my practices, I always started following the rule of thumb: if I amusing ANY maya shaders, they are first, and then I layer MIB shaders on top, never MIB first and then Maya on top. Oh, this also happened with the bumpCombiner transfer modes. Also, i have, to the best I can remember, never gotten it in a scene that had ONLY MIB shaders.

thats all I have, I will see if I can find someof my old scenes and recreate the solution for you.


CGTalk Moderation
03 March 2005, 08:09 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.