View Full Version : how to install GI Joe?

08 August 2004, 07:37 AM
i just downloaded gi joe 2.1 off of but it doesnt include documentation on installing. the description said that the documentation could be found at but as you all know, the website is currently down. can this script be used with maya 6? how do i install it? thanks

08 August 2004, 11:03 AM
Open GI_Joe.mel in a text editor. Near the top, under "Usage" it tells you how to install it. Really you just put the mel file and the GIJoe.lights file in your scripts folder. You need to edit a line in the mel folder to tell it where the lights file is.

Then launch it by typing GI_Joe, select the number of lights you want, then use the GUI to change lighting parameters. You can reopen the GUI by typing GI_Joe at any time.

Mostly the interface is self explainitory, but if you get stuck I have the docs - I can email them to you.

08 August 2004, 04:08 PM
I am also trying to make it work (OSX)...I follow excatly what you said DJX and it brings up the GUI but when I hit "Go Create" it says GIJoe.lights not found...and I am certain it is in the "Machintosh HD:Uers:Shared:Alias:maya:scripts:GIJoe.lights"; I doing anything wrong? are the lights and script supposed to be in the same directory? because that's what I did....any help would be greatly appreciated.


08 August 2004, 07:19 PM
i followed the instructions the best i could and i was able to at least bring up the gui after typing the GI_Joe command. however, when i go to hit create i get an error saying file not found. can you email me the documentation? thanks

Dr. Ira Kane
08 August 2004, 07:49 PM
make some effort and do a search i already replied to this some time ago.

08 August 2004, 07:50 PM
now, after hitting create, instead of getting a warning saying file not found, i get one that says no obect matches name:, i can't figure this out. i changed the directory location in the melscript under where it says // modify here the path of the imported scene. did i change it at the wrong place?

08 August 2004, 08:17 PM
i finally figured it out.....thanks guys.

08 August 2004, 04:35 AM
Can you please tell me how u got over the problem? I still get the same error when i hit Go Create saying file not found...any help would be greatly appreciated!

08 August 2004, 02:16 PM
Afr_CG: Im not sure about osx. The way you typed the path in your post (with all those colons) looks strange to me. Do you know the equivalent way to specify the path with unix style syntax (Im guessing something with / or \). Try that.

hikaru78: Your email addr is not in your public profile. However it looks like you may not need the docs now.

08 August 2004, 04:21 PM
Djx, that was the mistake...I typed the path wrong, just copied and pasted from the "file-info" menu...t works now, DJx THanx a million man


08 August 2004, 09:30 PM should double check every character you enter in the directory location in the gi_joe melscript. just as djx mentioned, i first used \ slashes instead of / slashes and that didn't work so use forward slashes. another thing i had to do was make my directory drive letter from lower case to upper case. for example, i had to change from c:/ to C:/ and then it worked after that. it can be easy for those small details to slip by and also make sure you actually have "GI_Joe.lights" attached at the end of the directory location. here's an examples of what i have:

// modify here the path of the imported scene.
string $pathL = "C:/Documents and Settings/Rich/My Documents/maya/6.0/scripts/GIJoe.lights";

i hope this helps
djx, does the documentation have tutorials and instructions on using the plugin script? if so, then i would like to have a copy. here's my email:


08 August 2004, 09:48 PM
DJX, Hikaru, thank you guys! thanx a whole lot! it is working and I second Hikary's request I wouldn't mind a documentation also :)

Thanx again guys.

08 August 2004, 02:50 PM
Afr_CG: Im happy to send docs, but no email addr in your public profile.

(You could send it to me via the private messaging system)

01 January 2005, 10:11 PM

can you tell me what you exactly did to get the script running.
i modified it and put it in the scripts folder.
(by the way maya on osx got tons of script folders)
but starting the script i only get

// Error: /Users/Shared/Alias/maya/scripts/GI_Joe.mel //
// Error: Line 1.1: Syntax error //


04 April 2005, 06:47 PM
i too am baffled about how to get GIJoe running on Maya 6.01 on OS X. if anyone has success on maya 6 on OS X could you please tell us how, specifically? after i change the path in the GIJoe,mel script to: string $pathL = "/Users/Shared/Alias/maya/scripts/GIJoe.lights";
and place the script and lights file there. i get a very long message in the script editor sayaing : ground lighting frozen, environment texture frozen, etc., etc., etc.. and no interface ever pops up or anything. could someone please help? getting very desparate. and i too need the documentation. maybe that will help. any ideas? input?
thanks and cheers!!

CGTalk Moderation
04 April 2005, 06:47 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.