View Full Version : Tutorial confusion...ARGHHH!

08 August 2004, 05:25 AM
Going through the tutorials for foundation. For the most part I am pleased--I think they have been put together quite well in terms of aquainting the user with some of Soft's interface particulars in the context of a real workflow. The interface is soo daunting and it can be difficult to present it in any order that makes sense. I think they have done a pretty good job of this. (I am talking about the cobblestoneAlley tute).

Well, I've moved on to the modeling tutorial (tutorial 3 or the Tutorial I group) and have found inconsistencies between the explicit instructions and the predicted results for some steps. I've repeated the processes several times and hunted around and can't solve my problem. This is most frustrating because I know there is a really simple explanation and that I'm a click or two away from the solution. But to get there I need a solid understanding of the UI which is why I'm doing the tutorials in the first place. Since the tutes aren't going overly into depth about the theory behind each step, the steps really need to be reliable to give a picture of workflow and how it all builds up into a finished result.

First problem: (tutorial 2: editing properties)
Some views have been preset so that things like GET>primative>curve>arc result in an object whose CVs are highlighted in the view. This is for the sake of the tutorial, but there is no explanation as to how to exit this mode. It isn't standard for a new scene. And in other views in the scene, the same selected object just shows the white wireframe without the blue points. I think the lack of clarity here is quite confusing.

Second problem: (tutorial 3: polygonal modeling/ bolting down the tank parts)
You make a bolt then are supposed to duplicate it along a circle. The instruction has you select the bolt, then Modify>Poly.Mesh>Duplicate Poly along Curve. I assume this tool works by first selecting the object, then invoking the tool, then picking the curve. Once this is done, they have you delete the original poly object, leaving the array of duplicates.
Now, these duplicates only seem selectable as a group--clicking one selects them all. You're supposed to rotate, scale, translate this group over to another object. But all the transformations seem to occur to each of the objects individually and not as a group. For the life of me, I can't find the right options in the interface to get them to tranform as a unit. They transform in unison but individually. It is exactly control of this kind of behavior that a tutorial like this should be demonstrating, not obfuscating. I know the solution is simple, BUT it isn't simple to discover in unfamiliar terrain. And I've now given over a great deal of my life to solving a problem that shouldn't be.

This is just the very first part of the most basic tutorials. Am I in for more of the same with the 60 odd hours of learning materials on the other 6 disks that shipped with Foundation? That would be a design for a CG Circle of Hell. (hey, now *there* is an idea for the next great time wasting thread--don't do it!)

HELP. please.

I think the general design of these tutorials is fantastic, but a few simple BUGS can really make them difficult and frustrating. Manuals need be user tested and debugged just like the software itself if they are to work. Btw, I'm a strong Maya user migrating to XSI and can only imagine how difficult this sort of thing must be for the newbies.

thanks in advance and


08 August 2004, 09:50 AM
Problem1: Click on the eye menu, and toggle the Hulls item.
Problem2: Might want to click COG at the right of the interface.


08 August 2004, 01:47 PM
Problem1: Click on the eye menu, and toggle the Hulls item.
Problem2: Might want to click COG at the right of the interface.


Thanks. Unfortunately, COG is not the solution to problem 2. Tried it before you posted and again after. Going through the explicit steps in making the bolts for tutorial 3 just doesn't work the way it should with the file that is provided. I'm sure I'll know why eventually, but for now, pure frustration where there should be the joy of learning.

Some more tutorial bugs-- in the section in which you put "air vents" in the tank, you are told to duplicate selected polys on the object using ctrl + d. This duplicates the polys as separate free floating polys when by the tutorial it is clear that the intent is to have polys which are basically extruded and remain part of the primary object. I found under Application>preferences...preferences>commands>duplicate options, it is indeed set to extrusion instead of duplication for polys, but it doesn't seem to work right. No idea why.

Having moved on a bit through the tutorial, the next breakdown occurs with section "Adding the legs to stand on". The ask you to select the bottom outside polys on some legs you've created and extrude them using ctrl+shift+d. The result is nowhere near the pictures provided. I am clearly not working in the right coordinate system, but i can't get it to the correct one to save my soul. And it certainly isn't preset in the provided file. The new extrusions don't just forward from the legs as feet that stay flat in the XZ plane as pictured, and no settings in the property editor will get them that way. I can only make them all go skewing wildly in their local spaces. FUBAR.

I get the feeling that there just wasn't any testing of the tutorials against the provided files for completeness. They wrote good tutes, but didn't quite polish them for precision and accuracy, leaving out steps they take for granted in terms of adjusting settings here and there that make all the difference.

XSI is making me feel like Tantalus and Sisyphus all at once right now. I want to feel Herculean.


08 August 2004, 02:12 PM
I went through that tutorial and also ran into some(not all) of your problems. I've been trying to remember what I did to get the bolts scaling sorted out but can't- I just sorted it out without thinking too much about it. I guess that came from working with LW for too many years and always dealing with one issue or another. :-) For the air tank vent problem, just use Extrude instead of Duplicating the polygons. There is something odd about why that doesn't work with Duplicate since it has worked while messing around with other things but not the air tank. Obviously something is being overlooked. I have no idea what your leg problem is- mine worked fine but it is possible I changed something without thinking twice about it. Perhaps you need to change to Local axis or something along that line. Franly I'm just loving the way modeling in XSI works- much more intuitive to me than when I was trying to learn MAYA.

08 August 2004, 02:57 PM
I have been going through the same tutorials and so far the only problems I have had were with come from some directions to right-click on objects for a menu (which I never get) but by left clicking Select I get the menu being talked about so I am not sure if this is a version thing or something in my settings. For the bolts, it sounds like you were set in local mode. I went through that section no problem from their directions. I even beveled the bolts and made 4 sets instead of 2.

For the air vents, I had the same problem with duplicating the vents. It didn't do any extruding. I just used the extrude tool to make it look right. Another think to play with when you get the vents right and smooth out the tank it to select the edges of the air vents and adjust their weighting to sharpen them up.

I'm just getting to the 'add legs' section so I'll let you know if I have any problems.

08 August 2004, 03:18 PM
- Try Alt-RMB instead to get context menus on objects

- For polygons moving locally (even when you don't have COG selected), check for the option "Transform components independently in local mode" (under the Transform menu on the MCP) This can cause problems if you have it unintentionally selected.

(Also the "context menu" button, or whatever it's called - the one the to the left of the right-side Ctrl button on the expanded keyboards, will also give you an object/component context menu).

capt chuck
08 August 2004, 03:56 PM
I ran into the same rotate and scale problems for the ring of bolts. I tried several of the things people suggested but the only thing that finally "sorta worked" for me was to rotate and scale the circle path that was used to make the duplicates in the first place. This sure feels like a hack and not was what was intended in the tut, but I did get bolts on the tank that way.

08 August 2004, 04:06 PM
Anyone having problems with the bolts - did you make your circle over the tank edge or did you just make a circle and then try to match things up? I set my circle up with the tank and had no problems so maybe that is where the issue is?

08 August 2004, 09:48 PM
I think the "duplicate" problem is due to it working differently depending on where it is done from. If you use "Duplicate single"(or CTRL D) under the Edit menu, it will do an extrude if that is the option selected in the Duplicate Options. However, the Duplicate command under Modify/Polymesh will NOT do it as an extrude. I know I was confused on this but I think I've got it figured out now(at least until some hidden Preference setting gets changed from my poking around).:-)

CGTalk Moderation
01 January 2006, 02:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.