View Full Version : Maya 2016 SP6 viewport lag/freezes (Need help!)


Strubey
05 May 2016, 01:17 PM
I've just got my new PC setup with 2 monitors, a NVIDIA GTX 980 and an Intel Core i7 6700K CPU (Both very slightly overclocked as well). Still, i'm experiencing these weird lag spikes/freezes for a couple of seconds when I click on objects in the viewport (the higher the polycount the more lag, especially with smoothed meshes). Selecting things from the outliner works great and even drag selecting the object starting from outside it usually works better. I've re-installed maya multiple times and I've even tried previous versions (as well as Maya 2015) and I had the same problem. I have the latest GPU drivers as well (364,72).

Starting to get desperate here, been troubleshooting for a very long time and can't seem to get it to work. Any help would be highly appreciated!


//EDIT

Was able to solve this problem by using the OpenGL Core Profile instead of the default OpenGL profile under Setting -> Display, at the bottom under Viewport 2.0 render options. I think it might have been a compatibility issue with regular OpenGL and Windows 10 or perhaps my GPU drivers.

Going to leave this thread up as help if someone else is experiencing the same problem. :)

skyliners
05 May 2016, 12:46 PM
Hello.

If the issue is still not fixed, can you try one thing?

1. Go to "nvidia control panel".
2. In the first tab where you can see rotating Nvidia logo, pause rotation. There is an option there. (keep window open)
3. Try Using Maya now. It should work fine now.

Let me know results.

Skuld
08 August 2016, 09:00 PM
Was able to solve this problem by using the OpenGL Core Profile instead of the default OpenGL profile under Setting -> Display, at the bottom under Viewport 2.0 render options. I think it might have been a compatibility issue with regular OpenGL and Windows 10 or perhaps my GPU drivers.
Thank you for sharing your solution! I was having the same problem and this is the only thing that I've tried that works so far. Thank you!! :)

AndrewPalmer3D
10 October 2016, 11:28 AM
Hello.

If the issue is still not fixed, can you try one thing?

1. Go to "nvidia control panel".
2. In the first tab where you can see rotating Nvidia logo, pause rotation. There is an option there. (keep window open)
3. Try Using Maya now. It should work fine now.

Let me know results.

So... I tried this and im shocked.. IT WORKS!!! WHY WHY WHY??

I was getting a strange lag whenever I rotated the viewport regardless of model density. About a .5 second load/lag.. using the above actually fixed it..

Again.. shocked but thank-you!!!

skyliners
11 November 2016, 07:01 AM
So... I tried this and im shocked.. IT WORKS!!! WHY WHY WHY??


Imagine spending years of saving on buying a machine which had this weird issue. I almost cried.

In my case I have Dell Inspiron 15 7000 laptop which has 2 graphic cards. Nvidia graphic card is on standby most of time. But keeping the window open with Nvidia logo keeps the card awake.

I am happy it works for dozens of people.

Visum
12 December 2016, 01:10 AM
Oh man this is GOLD!.
I was pulling my hair already not knowing what's going on and this single spinning thingy fixed it all lol,.


Thank you thank you thank you thank you thank you.


1