View Full Version : Set Keys Problem

02 February 2004, 09:46 AM
I have this problem with Maya 5 PLE (animating with generi_rig);I started blocking my animation; everything was fine,but next day when I reloaded I set all my keys and I could animate all the body except the Jaw and hands,so before I could animate both and still have the keys but I caīnt set more keys in the Jaw and hands itīs like freezed ,also I couldīnt delet those keys,I looked at the graph editor and the curves where like broken lines and couldīnt modify themŋŋ

I investigate a little and found this in the script editor(thatīs te problem);
currentTime 24 ;
rotate -r -os 31.998692 0 0 ;
// Result: 3 //
setKeyframe -breakdown 0 generi_head_ctrl.rotate;
// Result: 0 //
setKeyframe -breakdown 0 -hierarchy none -controlPoints 0 -shape 0 {"generi_head_ctrl"};
// Result: 0 //
// Warning: Current manipulator and active objects have no keyable attributes //
currentTime 22 ;

Anyone nows how to solve it?thanks


02 February 2004, 10:15 PM
sounds like you're referencing the rig. basically, if you reference a rig, there should be no animation on controllers on the rig. everything that is referenced is basically read-only, so if any of the controllers have animation on them, when they come into the scene, they're read only, and come up as dotted lines in teh graph edtir.

to solve it, just open up the rig, and make sure there are no anim curves on your jaw and whatever else...

if that STILL doesn't work, then the solution is a bit tricker...

02 February 2004, 09:43 AM
Hey thanks Macaronikazoo,could be also this the tricky solution somebody told me if I doīnt want to lose those keys?

One way to tell is if the field is orange in the attribute editor. Sometimes it can happen if you make the channels unkeyable. Just select the object in question, and click on Window->General Editors->Channel Control and make sure you have channels in there that are keyable.



02 February 2004, 10:17 PM
keys are still selectable, and editable if the channels are non-keyable...

however, if you lock a channel, then its keys become non moveable in the dope sheet, but they're still editable in the graph editor. the only way to describe what you're getting (ie dotted lines) that i'm aware of, is if the animCurves are referenced. and yeah, the node's name turns red if its referenced.

02 February 2004, 11:40 AM
Ok,I think I understand,I tried all but nothing(I canīt set keys)I would like to know the tricky solution,please,:rolleyes:

02 February 2004, 10:27 PM
the tricky solution is somehting like this: we use rig referencing everytime we do an animation here, and every now and then, we open a scene file, and rig has referenced animation curves being plugged into it.

so we'll open the rig file, and look for any keys, but there are none.

now, whats happening is, the anim curves have come detached from the control objects somehow*. So the anim curves are still in the scene, but they're not connected. now, when you open up the scene with the referenced rig, the REFERENCED anim curves - ie the detached ones from the rig - are connected to the control objects instead of teh ones actually in the scene, because they have the right name... its a little hard to explain by typing.

anyway, the upshot of all this, is that in your rig file, you have to select all anim curves, and see if they're connected to something. type this:

select `ls -type animCurve`;

to select them all. then in hypergraph, do an up/down stream, and select only the ones that aren't connected to something, and delete them.

and thats it. simple really. its only tricky because of the explanation really.

*(probably because one of the animators has done something stupid like doing a select all - break connections to delete keys instead of actually deleting the keys)

CGTalk Moderation
01 January 2006, 09:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.