XM Magdalena 3D print, GGeorgy (3D)
LC #42 Pipers Alley

View Full Version : Reverse Foot Problems in Maya 5

02-04-2004, 05:34 PM
I used do do my Reverse foot in Maya 4.5 parenting the ikHandles to curves ], so when I move my pelvis down it would flex my leg and the foot wouldn´s go under the floor ok???
Well this same setup doesn´t works quite well in maya 5. It only works when I set keys on the pelvis, then I have to scrub the timeline to see the result.
How do I do to get instant feedback???

02-04-2004, 06:03 PM
make all the ikhandles sticky, or download the 5.01 patch.

02-08-2004, 09:34 AM
On the same topic, I used to make my reverse foot setup by using SC ik from ankle to ball and ball to toe. Then with some clever grouping and by moving pivots you can get all the control one could ask for.

My problem is that SC ik are not behaving the same in Maya 5.0 because when I create one it rotates my joint all funky. Is this normal? In maya 4.5 the SC IK doesn't move the joint at all. What am I missing?

The problem does not occur with RP IK, just SC. It also does not happen when I disable the IK in the creation options.

02-08-2004, 10:04 AM
I just tried creating the foot Ik handles BEFORE my hip to ankle RP IK and they appear to be working fine now. Seems I can't create a SC IK from ankle to ball/toe after creating a RP IK from hip to ankle. It just goes all wonky, and rotates the joints in a unpredictable manner.

The order of creation was never a problem in Maya 4.5. Any ideas why it all of a sudden matters in Maya 5?

02-08-2004, 11:08 PM
I just took a look at Alias' PDF release notes for the 5.01 upgrade and under 'Character Setup' it says this:

.IK Handle creating causing unwanted rotation - The problem where adding an IK handle sometimes caused the joints to rotate randomly has been fixed.

Sounds like the 5.01 patch will fix my problem. *crossing fingers*

02-09-2004, 01:18 AM
Yep, the patch fixed it.

I just realized I've got four posts in a row. Nothings quite as fun as blabbering to yourself on a webforum. ;)

02-09-2004, 01:46 AM
Originally posted by modi
make all the ikhandles sticky, or download the 5.01 patch.


02-09-2004, 02:09 AM
Yeah, I never would've guessed that it would be a bug, seems to obvious to slip past beta testing. Thanks for the help modi.:thumbsup:

CGTalk Moderation
01-17-2006, 09:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.