View Full Version : error 651-problem with routers, but very very strange

01 January 2013, 04:31 AM
This is a problem I try to solve for several days, with no success:

My video card got busted and when I changed it, I couldn't connect to the internet anymore. Said "error 651 The modem (or other connecting device) has reported an error". I used a pppoe thing to connect, with the cable from the ISP. I have 2 ethernet adapters on the motherboard, both of them give the same error.
Now here is the very strange thing to me: This error is only in windows (7). However, I also have Linux (Fedora 17) on the very same computer, yet everything works fine, it connects to the internet no questions asked. The very same hardware!
So this is my question: are the adapters broke or not? How come linux can work fine with them but not windows?

Of course I reinstalled the drivers (the chipset and the adapters are from nvidia, so was the video cards both old and the new one). I searched on the internet, tried just about everything.

I also bought a router, it connects to the internet, but I can't access it with the old ethernet adapters, only with a new one in the pci slot.

Any Idea what is wrong with them?
What can i do to fix them?

01 January 2013, 06:33 AM
so your workstation is connect via ethernet to the router, which is connected to your DSL modem right?

if so, (which would seem logical).. why on earth would you have PPPoE configured in windows.

you can remove any PPPoE settings via control panel > internet options > connections and check to see if you setup or added a dial-up/vpn network. if so, delete it.

the PPPoE configuration should be handled by your "router".. unless its' not a real router, then well... that would be just wierd.

01 January 2013, 09:49 AM
Hi tswalk,
The router is a new addition. At first I was using the cable from the ISP without a router, so I needed the pppoe connection.
At the moment the connection is set up in the router, of course and I deleted it from the computer.
I can't access the router using the old ethernet adapters, only with a new one, It also says "unidentified network".
Yet in Linux works just fine.

01 January 2013, 02:18 AM
ok, makes more sense then.

we could probably go through a multitude of troubleshooting steps in windows, but I'm thinking in your case it may be just easier to un-install the network adapters, reboot, and see if the system auto discovers the new network adapters and setup.

that would be the easy fix if it worked.

control panel > device manager > expand network adapters

right click the network adapter and select 'uninstall'.. reboot.

see if it automatically locates the hardware and sets up for TCP/IP networking and 'discovers' the LAN properly.

let us know.

01 January 2013, 07:26 PM
I did what you suggested, didn't worked.
I am pretty much out of options, so I leave it as it is. I tried pretty much everything I found.
I would get over it, if I knew it is broken, but it works in Linux and this really annoys me.

So. i decided to buy a new network adapter, don't have the time to hunt errors all year.

Thanks for the reply.

01 January 2013, 07:21 AM
ya, these things annoy the crap out of me too.. you're not alone.

If you ever find time to check on this again, let me know what motherboard/nics you have, and i'll do some digging around too to see if anything helpful pops up.


well.. after doing a quick dig, i found several sites with similar suggestions. primarily seems that their objective is to replace the raspppoe driver or some other combination.. short of re-installing Windows, you could try this stuff.

this link seemed to have the most activity and comments... might spend some time digging through it:

01 January 2013, 09:29 AM
Thanks, I already saw those things, none worked. Then I reinstalled the system. I also tried with a new ethernet adapter and it worked.

This is the hardware I have:
motherboard: Asus P5N64 WS from 2008 here are the specs (
Ram: 3 x 2Gb DDR3 1333 Mhz
cpu: Core 2 Duo E7300 2666 Mhz
video: GeForce 8800GT (this was busted, now I am waiting for my new gtx670, until then 8800GS)
psu: 500W
hdd: 2x1Tb in raid, 1x256Gb for linux
usb: some 4 devices connected (mouse, keyboard, tablet, the monitor as a usb hub)

the ethernet adapters and the chipset is all nvidia, as you can see

CGTalk Moderation
01 January 2013, 09:30 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.