View Full Version : Trouble with 32bit floating files colorAtpoint

10 October 2012, 08:32 PM
I need help with 32bit floating files colorAtpoint
I am changing the color of the light driven by the colorAtPoint.
I found out that the colors that been read are very different to what they should be. If the created colour is very bright (r0.9653 g0.9722 b0.8013)//see download link at bottom// it will be that colour in maya (r0,957 g1 b0) or a dark colour (r0.007 g0.002 b0.004) will be in maya (r1 g0 b0.416). Do you have any idea where that is coming from?
I need that feature for my bachelor thesis and it took me three days already, if it is not working my whole bachelor theme won’t work out.

float $RGB[] = `colorAtPoint -o RGB -u .5 -v .5 file1`;
defaultPointLight(1, 1,1,1, 0, 0, 0,0,0, 1);
select -r pointLight1 ;
setAttr “pointLightShape1.color” -type double3 ($RGB[0]) ($RGB[1]) ($RGB[2]) ;

I am using
Maya 2013
32bit floating
I tried exr, hdr, tif32bit
The test files are generated with nuke and photoshop (tried both)

CGTalk Moderation
10 October 2012, 08:32 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.