XM Magdalena 3D print, GGeorgy (3D)
LC #42 Pipers Alley

View Full Version : Maya API & C++ Problem

08-18-2012, 01:59 AM
Hello All:

I would like to start lean Maya API and i follow the step from this:


But it's doesn't work

My C++ code:http://imgbox.com/g/BHShDRHuQ1

The C++ code is from C:\Program Files\Autodesk\Maya2012\devkit\plug-ins\helloWorldcmd.cpp

and my problem:http://imgbox.com/g/UX1xpsJziq

My software:Maya 2012 x64 & Microsoft visual C++ 2010 Express(installed 7.1 sdk already).

Help me please...

08-18-2012, 07:16 AM
This is not the hello world example but the helix. And instead of creating your own .sln, use first the one in the plugin dir. And do start with the hello world example first.

And what's the deal with the images? Please provide .txt files next time (http://pastebin.com/).

08-19-2012, 03:18 AM
Thank you very much,zoharl.

I created a new project with visual C++ 2010 Express and i follow the step from what i post

yesterday again.It's still error...

This is my error link:


Could you teach how to start step by step?

And Thank you so much for answer my problem~!!

08-19-2012, 03:25 AM
Sounds like you're having a very similar issue that I just had. Try following the steps I outline in the last post here:

08-19-2012, 07:25 AM
@KerKer: Okay, I'll repeat again: Under the maya installation dir there's the devkit\plug-ins directory. Search for the file helloCmd.sln and open it with VS, and try to build it.

@PeterRabel (http://forums.cgsociety.org/member.php?u=411354): Look for my previous posts. The wizard is redundant and can be problematic. You shouldn't use it.

08-19-2012, 07:38 AM


look for more

08-19-2012, 09:07 AM
Thank you very much zoharl and peterRabel

Thank you for your help and answer~!!

CGTalk Moderation
08-19-2012, 09:07 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.