View Full Version : Trouble with Python Image Library in maya 2013

08 August 2012, 04:24 PM
we recently upgraded to maya 2013 from 2012 and I am having trouble getting PIL to work.
I am getting the (quite common) error message:
# ImportError: The _imaging C module is not installed #

Both maya 2012 and 2013 are 64-bit, and both are using python 2.6.4. I checked my Path, and ensured that "_imaging.pyd" is present and on the path.

I ran "mayapy.exe" in command-line mode with verbosity on, and sure enough, mayapy from 2013 cannot import "_imaging", but 2012 can.

What could I have missed during the upgrade process that would cause this kind of problem?

08 August 2012, 07:40 PM
This may be a completely useless bit of info, especially as you mention you're just using 64-bit, but we have a 32-bit version of PIL installed, and when we forget and run the 64-bit Maya I'm sure we get exactly that error message too... you don't also have a 32-bit PIL installed that 2013 is somehow picking up do you?

08 August 2012, 10:09 PM
As far as I can tell, we only have 64-bit versions of PIL installed.

I have PIL installed for standalone Python (works fine) and for Maya 2012 (works fine), but doesn't work in 2013.

Is there a way for me to check how PIL was compiled?

08 August 2012, 10:24 PM
not sure, I don't actually deal with the setup of PIL, I only use it a bit. I'll ask my collegue who deals with that side of PIL about this tomorrow, see if he has any ideas...

08 August 2012, 02:04 PM
maybe this is useful, one of the programmers got this error.

C Run-Time Error R6034

maybe i need to get a new VS redist?

08 August 2012, 10:22 PM
Looks like PIL will need to be recompiled against Visual Studio 2010 to be compatible with Maya 2013.

08 August 2012, 05:06 AM
I think you just 'officially' verified my suspicions on this thread:

There's no limit to autodesk amateurishness!

Could anyone please try to explain to me - guess / take a shot in the dark - how can someone reach this decision in autodesk? Don't they have an experienced system architect, or is it just some two years skilled programmer who just decided to build the python modules in 2010, because that's what he has installed on his computer?!

08 August 2012, 01:44 PM
this is pretty annoying and feels like an arbitrary decision on autodesk's part from my perspective as a customer...

08 August 2012, 04:27 PM
this is pretty annoying and feels like an arbitrary decision on autodesk's part from my perspective as a customer...hahah, not like many of their other decisions then! :wip: at least they're consistant. ;)

I've just spoken to our guys and apparently we've fixed it by recompiling PIL ourselves

08 August 2012, 06:00 PM
I think you meant unlike.

Correct me if I'm wrong, but isn't python 2.7 or maybe a version above has vs 2010 as it's default compiler, and simply upgrading mayapy a bit would have solved all this trouble?

08 August 2012, 06:38 PM
I think you meant unlike.Nope, I was using sarcasm. too subtle?

CGTalk Moderation
08 August 2012, 06:38 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.