View Full Version : command no use with batch render

07 July 2012, 03:14 AM
Hey, all

i have a script to delete a render pass, like this:
DeleteCurrentPass "Passes.Depth"

in my scene, there are 2 render passes, one is the default_pass, the other is Depth, to run the code within the scene, it's ok. but if i use it as a script for batch render, i.e "xsibatch -script xxx -render myscene.scn", softimage will freeze after runing the code, any suggestion to this?


07 July 2012, 03:18 PM
try using the DeleteObj command instead of DeleteCurrentPass

08 August 2012, 01:44 AM
yup, i already tried with DeleteObj, the result is the same. Also, i even tried with this:
SelectObj xx, "BRANCH" or ("TREE)"
DeleteObj ()
SceneRefresh (
Still doesn't work!

08 August 2012, 07:02 AM
Have you tried making sure it's not your current/active pass, and then deleting it with deleteObj in branch mode?

CGTalk Moderation
08 August 2012, 07:02 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.