View Full Version : Confused about the Artisan Attribute Paint Family of Tools

06 June 2012, 05:11 PM
I am trying to initialize a Fluid Attribute Paint Context using 'artFluidAttrCtx' command so that the default attribute to paint is Velocity instead of Density. I am also trying to set the Clamp range and some other display properties, but no matter what I try, the Tool always initializes to the default settings.

Even editing it afterwards doesn't update the tool!
fluidCtx = cmds.artFluidAttrCtx('rs_fluidAttrCtx', i1='fluidPaint.png', p='velocity',
v=[0.0, 0.0, 1.0], usd=True, dv=True, cl='upper')


When I look at the Tool Settings UI, it's still in "Density" mode.
If i try:
cmds.artFluidAttrCtx('rs_fluidAttrCtx', e=True, p='velocity')
cmds.artFluidAttrCtx('rs_fluidAttrCtx', q=True, p=True)

I get back 'Density'....

What am I missing?
(Maya 2012 64bit Windows btw)

06 June 2012, 09:40 PM
Solved my issue. Due to my lack of understanding how Fluids work, I disconnected the fluid from the time input to keep the velocity field in stasis. This caused some interaction problems with Artisan.
Changing the Fluid to use a Static Grid and leaving the connection to Time solved my issue.

CGTalk Moderation
06 June 2012, 09:40 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.